Can`t bind squid to loopback



  • Hey there,

    i am not sure if what happens to me is caused due to a misconfiguration on my part but to make sure i would like to hear your advice.
    I am on PfSense 2.15 and i tried squid-stable (2.7.9) and squid3 (3.1.20)

    Everytime i try to bind squid to the loopback and enable transparent proxy mode (which is what i desire for my clients) every webpage i try to retrieve gives me an error
    (The requested URL could not be retrieved)
    I tried to disable transparent mode and created a port forwarding rule manually to achieve manually what i assume the transparent mode checkbox does automatically.
    As soon as i apply the port forwarding rule the error message "The requested URL could not be retrieved" shows up again, but if i unbind loopback everythign seems to work.

    Is there any explanation for this, normally binding squid to loopback should work right?
    I appreciate your help, thank you in advance.

    Dennis



  • Noones any explanation for this issue?
    I just want to understand where the problem is, even if the solution is pretty obvious (that is, dont bind squid to loopback)
    If someone maybe can explain to me why this problems occurs, that would help me a lot :)


Log in to reply