APU install stack on boot



  • HI, I just got a new Alix APU 4G RAM and msata HD but I'm unable to install the PFsense on it :(
    I create the SD according to various post, and it boot fine from it but I can't stop the boot (F12) I try under Ubuntu and W7 same problem the boot keeps going until it stop with:
    Manual root filesystem specification:
      <fstype>:<device>Mount <device>using filesystem <fstype>eg. ufs:/dev/da0s1a
                          eg. cd9660:/dev/acd0
                          This is equivalent to: mount -t cd9660 /dev/acd0 /

    ?                  List valid disk boot devices
      <empty line="">Abort manual input

    mountroot>

    Please help

    Thanks</empty></fstype></device></device></fstype>



  • Which Firmware is on your APU?

    Try the latest Firmware from here:
    http://www.pcengines.ch/apu1c.htm

    I've had similar problems, flashed Build 9/8/2014 (beta, reduced "spew level") and everything went smooth after that.

    Good Luck!
    Harry



  • OK thanks .
    I will give it a try.



  • Ok I installed PFS on the MSATA ( used the dd with the latest embedded image ) but when it start the system don't boot complitly and on the board I have only the first led on the left side ON all the others are off ??

    I got a USB-MSATA cable so I try to see if I can change the script on the MSATA from my Ubuntu pc but is not reconnize the partition ???

    any suggestion is welcomed :)



  • I did a full install with the pfSense-memstick-serial-2.2-DEVELOPMENT-amd64 (was Alpha at that time, now is Beta) version.
    To do this you need to have a nullmodem cable connected to the serial port of the APU in order to see the boot and install screens with a terminal software like putty on Windows (there are several detailed instructions here on the forum).
    During the install choose the embedded kernel (no VGA, no Keyboard).
    This worked fine for me.

    There are several discussions here which version to install on a ssd (nano or full). People are concerned about are the lifetime of the ssd.
    I have to admit I never even tried nano, as the possibilities are more limited and I do not use any heavy writer package, more or less plain pfSense. So far I have not regretted to go that route, all my 6 boxes are up and running fine without a single problem since months. Possible downtime is also not so much of a problem. In case of a dead ssd I only need to put in a new one, install pfS and throw the config backup on it. A matter of minutes, half an hour the max.
    That is tolerated in my scenarios, but your mileage may vary.



  • First thanks to all.
    I solved installing the image with linux command "dd" using the MSATA-USB adapter ( did OK on second try :) )

    :D