Problemas com Squid Failover Pfsense 2.1.5



  • Boa Tarde

    Estou com um problemas que esta me deixando irritado e me fazendo deixar de lado o Squid.
    tenho 2 links de internet e estou fazendo o failover tranquilamente, quando eu ativo o squid ele funciona normal com os 2 links, só que quando cai um dos meu links ele apresenta eu erro de cache.

    Link -1 Dedicado IP-Fixo
    Link -2 PPoE

    se alguém já passou por isso e conseguiu resolver compartilhe.

    Grato



  • Geraldo estou com o mesmo problema depois de atualizar para a versão 2.1.5 e tambem estou procurando soluçao. Configurando em Advanced Miscellaneous - Use sticky connections e Allow default gateway switching o pfSense faz o load balancing e fail over corretamente mas o squid não muda o default gateway, o default gateway tem que ser alterado manualmente no System Routing Gateways para o proxy voltar a funcionar no outro link.



  • Fez o teste adicionando a linha abaixo no campo Custom ACLS (Before_Auth) do squid3?

    tcp_outgoing_address 127.0.0.1



  • Utilizo o squid3, estou colocando estas configurações no Custom Options e no Firewall Floating Rules






  • Vc esta utilizando o squid em modo transparente ou autenticado?
    Criou a regra de Nat -> Outbound?



  • Sim gilmarcabral, Squid3, não transparente e sem autenticação, as regras Outbound estão ok, sem proxy Fail Over dos links funciona normalmente.