Integração Squid + SquidGuard + AD = não pedir login e senha toda vez



  • Prezados bom dia.

    Consegui fazer todas as integrações corretamente. Meu pfsense está validando os usuarios no AD corretamente, no entanto, estou tendo dois problemas que gostaria de resolver.
    São eles:

    Problema 1
      - Se o usuário jose está configura no AD para acessar os micros contabil1 e atendimento1 (determinados computadores) o sistema não valida mais a senha.  So vai validar seu eu tirar a restrição de maquinas e colocar para ele acessar todos os computador. Detalhe, ele está fazendo isso da maquina que ele tem permissão de usar.

    Problema 2
      - Toda vez que o usuário tenta navegar o sistema pede login e senha.  Qual o resultado disso, todo que é programa que usa a internet agora ta pedindo login e senha ( antivírus, office, etccc). Existe alguma formas de fazer essa integração por completa e o PFSense pegar o login e senha que ele digita ao usar o computador (login de rede) e passar a validar por ali, desta forma creio eu que não vai ficar mais solicitando sempre login e senha.

    Aguardo orientações.. Obrigado….



  • @marcelfreitas:

    Prezados bom dia.

    Consegui fazer todas as integrações corretamente. Meu pfsense está validando os usuarios no AD corretamente, no entanto, estou tendo dois problemas que gostaria de resolver.
    São eles:

    Problema 1
      - Se o usuário jose está configura no AD para acessar os micros contabil1 e atendimento1 (determinados computadores) o sistema não valida mais a senha.  So vai validar seu eu tirar a restrição de maquinas e colocar para ele acessar todos os computador. Detalhe, ele está fazendo isso da maquina que ele tem permissão de usar.

    Problema 2
      - Toda vez que o usuário tenta navegar o sistema pede login e senha.  Qual o resultado disso, todo que é programa que usa a internet agora ta pedindo login e senha ( antivírus, office, etccc). Existe alguma formas de fazer essa integração por completa e o PFSense pegar o login e senha que ele digita ao usar o computador (login de rede) e passar a validar por ali, desta forma creio eu que não vai ficar mais solicitando sempre login e senha.

    Aguardo orientações.. Obrigado….

    Tem os tutoriais do Gustavo no youtube sobre autenticação ntlm com o pfsense atuando como Domain Member.

    Creio que seja esse vídeo aqui
    Youtube Video

    Esse tutorial é para Proxy Transparente e não proxy ativo.



  • Obrigado pelo retorno



  • gostaria de saber se ese tutorial serve para pfsense x64 e com proxy ativo ?



  • Sim serve. eu consegui fazer funcionar assim…



  • Seu AD é samba ou windows?



  • Boa tarde,
    eu estou começando a usar o pfsense agora e estou tentando fazer a autenticação do squid com Active directory (Windows).
    Eu estou usando o pfsense 2.1.5-RELEASE (amd64), e instalei os pacotes squid3-dev - version 3.3.10 pkg 2.2.6, squidGuard-squid3 - version 1.4_4 pkg v.1.9.5.
    Fiz toda a configuração de autenticação de acordo com vários tutoriais, fiz um telnet na porta 389 do servidor AD e funcionou, mas o navegador fica pedindo a senha, e no cache.log aparece o seguinte erro:
    2014/10/15 13:50:39 kid1| Starting new basicauthenticator helpers…
    basic_ldap_auth: WARNING, LDAP search error 'Operations error'
    basic_ldap_auth: WARNING, LDAP search error 'Operations error'
    basic_ldap_auth: WARNING, LDAP search error 'Operations error'

    Eu coloquei o ntp para buscar a hora do servidor AD também.



  • verifique a senha, se tiver caracteres especiais pode nao funcionar



  • Lucas,
    Eu também fiz este tipo de teste. Coloquei uma senha simples e apresentou o mesmo erro.



  • entao sua configuraçao esta errada, poste um print delas..



  • Segue a configuração:

    ![squid com autenticação AD.jpg](/public/imported_attachments/1/squid com autenticação AD.jpg)
    ![squid com autenticação AD.jpg_thumb](/public/imported_attachments/1/squid com autenticação AD.jpg_thumb)



  • deixe o attribute em branco (remova o uid) e o search comloque entre (sAMAccountName=%s)

    OBS: o seu administraDor é com D mesmo?



  • fiz conforme vc orientou e continua aparecendo o seguinte erro no cache.log:

    2014/10/16 09:52:20 kid1| Starting new basicauthenticator helpers…
    basic_ldap_auth: WARNING, LDAP search error 'Operations error'
    basic_ldap_auth: WARNING, LDAP search error 'Operations error'
    basic_ldap_auth: WARNING, LDAP search error 'Operations error'

    Você sabe me dizer o comando para testar essa autenticação via linha de comando?



  • nao.. mais sevoce for em Diagnostics, temuma ferramenta Authentication, la voce consegue testar.. so nao sei se serve pro squid tambem..
    pelo erro parece ser algum erro na string de consulta.. mais pelo seu print parece estar correto… o firewall do seu AD esta destivado?



  • Bom Dia!

    Normalmente este erro ocorre porque ele não esta conseguindo encontrar sua base de objetos do tipo usuário.

    Aqui na empresa por exemplo, esta hierarquizado da seguinte maneira

    DOMINIO.LOCAL
    -OU=NOME SEGUNDONOME
      –OU=DEPARTAMENTOS
      ---OU=USUARIOS

    Então no LDAP base domain eu informei o seguinte atributo: OU="NOME SEGUNDONOME",DC=DOMINIO,DC=LOCAL

    Na OU="NOME SEGUNDONOME"… coloquei entre aspas pois o nome da OU possui espaço.

    Espero ter ajudado.


Log in to reply