2.2-BETA on hyper-V 2012/R2 CARP remains in INIT



  • Hi,

    I've been testing with the latest pfSense on a hyper-v 2012 R2 cluster with two pfSense installations configured in a HA setup.

    When configuring CARP, both systems remain in INIT state. On both virtual machines MAC Spoofing is enabled as required.

    I've read that on 2008 clusters this has been working without a problem and I suspect that 2012 and 2012R2 might not be working due to the new virtual switch port acl's features…

    Somebody has any suggestions on where we need to look further to get this working ?

    Changing hypervisor is not an option...

    Kind regards,
    Wesley

    EDIT- added the system log part indicating a failure for kernel: ifa_del_loopback_route: deletion failed: 3

    Sep 20 12:17:02 check_reload_status: Syncing firewall
    Sep 20 12:17:02 kernel: carp: demoted by 240 to 480 (pfsync bulk start)
    Sep 20 12:17:03 php-fpm[17541]: /system_hasync.php: waiting for pfsync…
    Sep 20 12:17:03 php-fpm[17541]: /system_hasync.php: pfsync done in 0 seconds.
    Sep 20 12:17:03 php-fpm[17541]: /system_hasync.php: Configuring CARP settings finalize…
    Sep 20 12:17:03 php-fpm[55312]: /rc.filter_synchronize: Beginning XMLRPC sync to https://172.16.0.5:443.
    Sep 20 12:17:03 php-fpm[55312]: /rc.filter_synchronize: XMLRPC sync successfully completed with https://172.16.0.5:443.
    Sep 20 12:17:05 php-fpm[55312]: /rc.filter_synchronize: Filter sync successfully completed with https://172.16.0.5:443.
    Sep 20 12:17:11 kernel: ifa_del_loopback_route: deletion failed: 3
    Sep 20 12:17:11 kernel: carp: demoted by -240 to 240 (vhid removed)
    Sep 20 12:17:11 kernel: hn0: promiscuous mode disabled
    Sep 20 12:18:07 kernel: carp: demoted by -240 to 0 (pfsync bulk fail)
    Sep 20 12:18:14 kernel: hn0: promiscuous mode enabled
    Sep 20 12:18:14 kernel: carp: demoted by 240 to 240 (interface down)
    Sep 20 12:18:15 kernel: carp: demoted by 240 to 480 (pfsync bulk start)
    Sep 20 12:18:16 php-fpm[59959]: /carp_status.php: waiting for pfsync…
    Sep 20 12:18:16 php-fpm[59959]: /carp_status.php: pfsync done in 0 seconds.
    Sep 20 12:18:16 php-fpm[59959]: /carp_status.php: Configuring CARP settings finalize…



  • Same problem here, even when i enable Mac Address Spoofing on the Carp interfaces  :-[

    CARP has detected a problem and this unit has been demoted to BACKUP status.
    Check link status on all interfaces with configured CARP VIPs.

    CARP Interface 6 Virtual IP Status

    LAN@1  192.168.101.240  init  INIT

    EDIT:
    I work with Hyper-v Server 2012 (not R2)



  • Probably should check to allow multicast frames to travel on the virtual switch.
    This used to be a problem in vmware some years before as well.

    Normally should troubleshoot this by packet captures and check if both systems can see advertisments of the other.



  • hi there,

    any progress regarding this topic?
    that would be the exact setup we would love to accomplish.

    thank yo very much =)



  • It's a driver issue that we'll be working with Microsoft to fix post-2.2 release.



  • i'l have tested the 2.2 RC today, same problem….. :'(

    CARP has detected a problem and this unit has been demoted to BACKUP status.
    Check link status on all interfaces with configured CARP VIPs.

    CARP Interface Virtual IP Status

    LAN@1  192.168.101.93  init  INIT

    Is there an update about that?



  • @Dennis:

    Is there an update about that?

    Same status as before:

    @cmb:

    It's a driver issue that we'll be working with Microsoft to fix post-2.2 release.



  • Was it ever working with previous hyperv versions? We have set it up today on hyperv 2008 r2 and it is stuck in init state. =[

    Thank you very much



  • It's never worked.


Log in to reply