3xWAN, all same gateway problem



  • I was able to make the 2 work together by bridge mode and using a router to the second one.
    What I'm gonna do to my 3rd WAN work so it does not conflict? Thanks



  • Make it a LAN?



  • Pardon me, I'm really novice in networking.. :-[ does that mean I should make it static and assign to a local IP?



  • I was being a little bit sarcastic….  Joking.

    Well - pfsense doesn't like having multiple WANs with same gateway.

    Its cool that you managed to get 2 to work.

    I can think of a way to get all three to work, but its not ideal.

    It involves double NAT for at least 2 WANS.  I've never tried.

    However, it seems to me that 1 WAN could be directly connected to modem.

    The other 2 modems could then go to a cheap router that will then allocate a private IP to pfsense WAN
    The two routers would need to have different subnets on the LAN side and this way, pfsense would be seeing 3 different gateway addresses for 3 different WAN IPs
    Seems it should work.

    2 of the WAN interfaces would be double NAT, which is fine for many applications.

    For things that don't like layers of NAT, you can use manual outbound nat to make sure the directly connected WAN gets used.

    So, thats things like Xbox, some SIP and maybe skype clients.

    I'm sure there are many ways to force it to work, but this seems easiest to me.

    I assume you are simply trying to get more bandwidth by aggregating several modems and this is not a failover plan?



  • @kejianshi:

    I assume you are simply trying to get more bandwidth by aggregating several modems and this is not a failover plan?

    Yep, not a failover plan. Just separating other port connections.

    Thanks really for the reply but i'm clueless how to double-NAT.
    I attached a screenshot of my manual outbound NAT and also here are some infos:

    WAN1 = 192.168.1.1
    WAN2 = 112.206.X.X (bridge mode)
    WAN3 = 192.168.1.1 (tried to change it's address but I can't access when it's plugged in pfsense)
    PFSense = 192.168.0.1

    ![Screen Shot 2014-09-21 at 9.18.11 AM.png](/public/imported_attachments/1/Screen Shot 2014-09-21 at 9.18.11 AM.png)
    ![Screen Shot 2014-09-21 at 9.18.11 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2014-09-21 at 9.18.11 AM.png_thumb)



  • When you plug a router into pfsense WAN you have to go to interfaces > WAN (or whatever you named it…  maybe opt)

    Then uncheck "block private IP"

    You don't need to know how to double nat.

    When you plug a routers lan into pfsense WAN its double nat.

    Also, plug a laptop into the router lan BEFORE you ever try to hook it to pfsense.

    Then change its IP and subnet etc.

    For instance

    modem 1 lan 192.168.50.1
    modem 2 lan 192.168.51.1

    like that before you ever hook it into pfsense and be sure to no block private IP on the pfsense wans



  • oh damn, rookie mistake.. I just need to disable-enable my network in control panel after changing router's address.
    All good now. Thanks a lot.



  • Well - I don't typically go around telling people how to double NAT their pfsense on purpose, but I've not another good answer to your problem.