TP-Link TL-WN851ND (AR9227) Doesn't seem to work in NG mode



  • I just loaded up pfsense 2.2 Beta (pfSense-memstick-2.2-BETA-i386-20140919-1451) with a TP-Link TL-WN851ND (AR9227 chipset) wireless card in it. The first thing I wanted to do is test out the new "N" wireless access point capabilities. However, for some reason it doesn't appear to work in "NG" mode. When I put it in either "G" or "B" mode, I can actually see the SSID being broadcast. (I haven't done further testing yet). I am not sure what to make of it or what logs I should check to see if there are any errors. These entries below did pop up on the console but I am not sure at what point of my testing they occurred. Thanks.

    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning recursive reset path!
    ath0: ath_reset: concurrent reset! Danger!



  • I know it's an older thread - but I'm having the same issue with an AR9287 card.



  • Having the same issue (using an AR9227 card). Have you come up with some workarounds or solutions?



  • Several people have found things that work for them in this thread.
    https://forum.pfsense.org/index.php?topic=83424.0



  • @cmb:

    Several people have found things that work for them in this thread.
    https://forum.pfsense.org/index.php?topic=83424.0

    Finally got around to re-testing again using the RC. The suggestions in the other thread helped. Unfortunately, still no connections above 54Mbps.

    I set the regulatory settings to FCC and USA/FCC.
    I HAD to manually select the channel or it would not come up when "NG" mode was selected.
    I also did increase the key rotation times. Not sure if that helped though.

    I would have to agree that so far the "N" access point stuff is definitely unstable. I am REALLY looking forward to this being fully functional.

    –-a couple of minutes later---
    I re-read the other thread and I checked the WME option. I now get more than 54Mbps connections but it seems to bounce around a LOT.

    Maybe the WME option can be automatically enabled when "N" is used? I am just basing that off of someone in the other thread saying QoS is required for "N".


Log in to reply