Help setting up OPT1 to Web (SOLVED)



  • I have a pfsense box with three gigabit NICs.

    WAN –> LAN
            --> OPT1

    All of the them are exactly the same but I can only get internet on the LAN NIC. If anyone would be so kind as to help with this delima im facing I would be forever grateful.


    ![Firewall Rules.JPG](/public/imported_attachments/1/Firewall Rules.JPG)
    ![Firewall Rules.JPG_thumb](/public/imported_attachments/1/Firewall Rules.JPG_thumb)



  • Only LAN has a default WAN access rule.  Other interfaces need to have it added:

    OPT1 tab

    ID Proto Source Port Destination Port Gateway Queue Schedule Description
      IPv4* *     *   ! LAN net   *   *       none Default    Allow DMZ to NOT LAN


  • LAYER 8 Netgate

    Looks like he has the rules.  Interesting OPT1 isn't showing speed/duplex.  Is it plugged in?



  • @Derelict:

    Looks like he has the rules.  Interesting OPT1 isn't showing speed/duplex.  Is it plugged in?

    Yeah, I'm just trying to make sure I get the OPT1 configured right before I switch over the whole network.

    @KOM:

    Only LAN has a default WAN access rule.  Other interfaces need to have it added:

    OPT1 tab

    ID Proto Source Port Destination Port Gateway Queue Schedule Description
      IPv4* *     *   ! LAN net   *   *       none Default    Allow DMZ to NOT LAN

    I added this to the list and still no success…  :-
    I'm rather new to pfSense so this is a learning process also.



    ![new rules.JPG](/public/imported_attachments/1/new rules.JPG)
    ![new rules.JPG_thumb](/public/imported_attachments/1/new rules.JPG_thumb)


  • LAYER 8 Netgate

    Really the only other thing it could be is "block private/bogon networks" checked on OPT1 or you've turned on manual outbound NAT and there are no NAT rules for the OPT1 network.  If none of that is true I'd check everything else on the network before looking further at pfSense.



  • @Derelict:

    Really the only other thing it could be is "block private/bogon networks" checked on OPT1 or you've turned on manual outbound NAT and there are no NAT rules for the OPT1 network.  If none of that is true I'd check everything else on the network before looking further at pfSense.

    I have my NAT to auto and these are the rules it has applied… Im not really sure why it isnt working. Nothing works when I plug it into OPT1 but as soon as its plugged into LAN the internet and everything works.





  • LAYER 8 Netgate

    Dude.  What's with the /32 netmask on 192.168.2.1/32 ???  You probably want that to be /24.  Check your OPT1 interface settings.



  • @Derelict:

    Dude.  What's with the /32 netmask on 192.168.2.1/32 ???  You probably want that to be /24.  Check your OPT1 interface settings.

    It must have slipped by me, still won't connect to internet though. I'm not really understanding why im having such a problem with OPT1…


  • LAYER 8 Netgate

    Set OPT1 to /24, Check DHCP, check NAT, make sure your pass rule is there on OPT1 and it'll work.



  • In the first pic, LAN has negotiated a 100 connection.

    OPT1 has negotiated no connection at all.  Is OPT 1 not plugged into anything?

    Seems like something is up with the interface or the cable or the interface its connection to on the switch.



  • @Derelict:

    Set OPT1 to /24, Check DHCP, check NAT, make sure your pass rule is there on OPT1 and it'll work.

    Well… I didn't have DHCP checked for OPT1. Needlessly to say I feel like an idiot, but thank you so much. It works now  ;D



Log in to reply