Portal captive não redireciona pra página de autenticação (RESOLVIDO)



  • boa noite galera,
    Fiz um teste com o captive portal porém ele não redireciona automaticamente no navegador para a página de autenticação, quando coloco o endereço: 192.168.0.1:8000 ela aparece, porém, quando abro o navegador ou digito um site qualquer ele não redireciona. Vi aqui no fórum umas soluções tipo:

    Em DNS Forwarder deixe habilitado

    *Enable DNS forwarder
    *Register DHCP leases in DNS forwarder
    *Register DHCP static mappings in DNS forwarder

    e, também a de ir em: System -> Advanced -> System Tunables -> net.inet.ip.fastforwarding marcada como ativa (1) e colocar como desativada (0)

    Porém, mesmo assim, continuou sem redirecionar, funcionando apenas quando coloco o endereço acima com o :8000.

    Alguém tem alguma dica?



  • @faustovianna:

    boa noite galera,
    Fiz um teste com o captive portal porém ele não redireciona automaticamente no navegador para a página de autenticação, quando coloco o endereço: 192.168.0.1:8000 ela aparece, porém, quando abro o navegador ou digito um site qualquer ele não redireciona. Vi aqui no fórum umas soluções tipo:

    Em DNS Forwarder deixe habilitado

    *Enable DNS forwarder
    *Register DHCP leases in DNS forwarder
    *Register DHCP static mappings in DNS forwarder

    e, também a de ir em: System -> Advanced -> System Tunables -> net.inet.ip.fastforwarding marcada como ativa (1) e colocar como desativada (0)

    Porém, mesmo assim, continuou sem redirecionar, funcionando apenas quando coloco o endereço acima com o :8000.

    Alguém tem alguma dica?

    Liberou a porta ? está em http ou https?



  • Na configuração do Captive na aba: Allowed IP Address, inclua seus servidores DNS, ele não deve estar redirecionando pois não está resolvendo os nomes dos sites. Para saber se o problema é realmente esse, acesse um site pelo seu IP e veja se redireciona, exemplo: http://200.147.67.142 (uol.com.br)



  • @JuniorAndrade:

    @faustovianna:

    boa noite galera,
    Fiz um teste com o captive portal porém ele não redireciona automaticamente no navegador para a página de autenticação, quando coloco o endereço: 192.168.0.1:8000 ela aparece, porém, quando abro o navegador ou digito um site qualquer ele não redireciona. Vi aqui no fórum umas soluções tipo:

    Em DNS Forwarder deixe habilitado

    *Enable DNS forwarder
    *Register DHCP leases in DNS forwarder
    *Register DHCP static mappings in DNS forwarder

    e, também a de ir em: System -> Advanced -> System Tunables -> net.inet.ip.fastforwarding marcada como ativa (1) e colocar como desativada (0)

    Porém, mesmo assim, continuou sem redirecionar, funcionando apenas quando coloco o endereço acima com o :8000.

    Alguém tem alguma dica?

    Liberou a porta ? está em http ou https?

    Então, ele ta com o acesso padrão do pfsense, tudo liberado, o web do pfsense ta na porta 80 mesmo (também padrão)



  • Após muito penar, emular, fazer e refazer descobri qual era o meu erro!!
    É o seguinte, eu havia colocado no Servidor DHCP os DNS primários e secundários, lá era necessário deixar o campo em branco, por isso que o captive não redirecionava! Espero que isso ajude a quem mais esteja enfrentando o mesmo problema!!

    Abração a todos e obrigado!



  • na verdade irmão, o dns tem de ser o do próprio servidor pfsense, dai ele redireciona todo acesso ao captive portal! já o secundário pode ser outro!