[SOLVED] (Yet another) no WAN connection



  • I had to rebuild my pfSense server due to a hard drive failure.  The previous build was running pfSense 2.1 without any problems.  When I rebuilt I performed a clean install of pfSense 2.1.5.  Now I am unable to reach the internet from my LAN.  My configuration is simple:

    Comcast -> Motorola Surfboard 6120 -> em0:pfSense:em1 -> LAN

    Here is what I have tried so far:

    * I've replaced pfSense with a Netgear FVS318G and everything works fine.
      * I've connected a laptop directly to the Surfboard and everything works fine.
      * I've spoofed the Netgear MAC address (even though when I connect my laptop the Surfboard happily accepts the new MAC).
      * I've unchecked the "block local addresses" checkbox in the WAN settings.
      * I've rebooted the Surfboard repeatedly leaving it powered off for up to several hours.
      * I've powered everything down, powered up the Surfboard, waited for it to cycle, then powered up the pfSense server.

    This is a clean install, I haven't created any firewall rules.

    I don't know what to try next.  I would be very grateful for any suggestions.



  • It seems I was able to resolve my issue though I'm not entirely sure why this worked.

    My first step was to swap the WAN and LAN interfaces.  When I did the pfSense acquired a WAN address but I was unable to connect on the LAN interface.

    Naturally I assumed I had a bad NIC but I tried one last thing: I went into BIOS and disabled both interfaces, rebooted, then went back into BIOS and re-enabled both interfaces.  Now everything works!  I can run the WAN on either NIC successfully.

    Don't know why this worked but perhaps this will help someone else in the future.


  • Netgate Administrator

    Are they on-board NICs? Did you actually remove the power completely? Sometimes a component can get stuck in an odd configuration that can only br cleared by de-powering it. Many motherboards will supply some power, especially to NICs, in standby so have to physically remove the power cord.

    Steve



  • Both NICs are on the motherboard.  I don't believe I physically unplugged the server so you may be on to something there.


Log in to reply