Mobile IPSec: no peer config found

    Sep 23 22:05:31	charon: 14[IKE] <3> no peer config found
    Sep 23 22:05:31	charon: 14[CFG] looking for XAuthInitPSK peer configs matching[]

    The mobile IP Sec client was working in an old Alpha snap I was running–after upgrading to the latest beta snapshot the client would connect but it would fail to pass any traffic.  I removed all of the existing configuration and rebuilt it and now it won't connect.  The main difference appears to be lack of a "peer identifier" in the Phase 1.

    PSKs currently exist for: any, allusers, myemailaddress

    I've tried that email address in the group setting (OSX client) and blank in the group setting.

    I've tried the Group Authentication under mobile client as none and system.

    I've tried using different My Identifiers: IP, Distinguished Name, User Distinguished Name

    Running this snapshot: 2.2-BETA (amd64) built on Tue Sep 23 13:29:41 CDT 2014

  • Can you share /var/etc/ipsec/ipsec.conf sanitized and your ipsec section from config.xml?

  • # This file is automatically generated. Do not edit
    config setup
            uniqueids = yes
    conn con1
            aggressive = yes
            fragmentation = yes
            keyexchange = ikev1
            reauth = no
            rekey = no
            reqid = 1
            installpolicy = yes
            type = tunnel
            dpdaction = clear
            dpddelay = 10s
            dpdtimeout = 60s
            auto = add
            left = #.#.#.#
            right = %any
            leftid = #.#.#.#
            ikelifetime = 86400s
            lifetime = 28800s
            rightsourceip =
            rightsubnet =
            leftsubnet =
            ike = 3des-sha1-modp1024!
            esp = aes256-sha1,aes192-sha1,aes128-sha1!
            leftauth = psk
            rightauth = psk

    I noticed that the peer ID info is in the config, but there isn't anywhere to set it in the GUI.

            <ipsec><preferoldsa><client><enable><user_source>Local Database</user_source>

Log in to reply