A VLAN with the tag XYZ is already defined on this interface



  • Hi all,

    today one of my pfsense box give me an error when defining a new vlan:

    • Interfaces -> Assign -> VLANs -> +
    • parent Interface -> em0
    • vlan tag 111
    • Description MyVLAN

    After a few second of unresponsive web page and unreachable icmp packets, I got this message:

    The following input errors were detected:

    A VLAN with the tag 111 is already defined on this interface.

    I'm pretty sure that I never configured vlan 111 and this is actual vlans defined:

    em0 100 LAN aaa edit  delete
    em0 101 LAN bbb  edit  delete
    em0 103 LAN cccs  edit  delete
    em0 104 LAN ddd  edit  delete
    em0 105 LAN eee edit  delete
    em0 106 LAN fff edit  delete
    em0 107 LAN ggg  edit  delete
    em0 108 LAN hhh edit  delete
    em0 109 LAN iii  edit  delete
    em0 200 LAN jjj edit  delete
    em0 190 LAN lll  edit  delete
    em0 130 LAN mmm edit  delete
    em0 110 LAN nnn edit  delete

    I've tried a reboot, no changes.
    I've tried another vlan tag (ex 112), no changes.

    2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:50 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    Any ideas?

    Thanks!!

    BR

    Simon



  • Hello,

    an update to the latest version 2.1.5 did not solve this weird behaviour.

    Anyone can helpme?

    Thanks

    PS: If I try to remove a vlan, i get this message: "Fatal error: Call to undefined function getext() in /usr/local/www/interfaces_vlan.php on line 66 ".
    BTW, vlan is removed.



  • That getext error just a typo in a very rarely hit portion of that code I just fixed. What it was trying to tell you as an error is "Wrong index supplied", meaning you submitted the page somehow with an empty ID to delete.

    Backup your config, open it in a text editor, what does the <vlans>to</vlans> section look like?



  • @cmb - I put in a pull request to fix other instances of the same typo in 2.1.5, save you or someone else having to find those in future.
    Will do same in master while eating breakfast.



  • Thanks Phil, I was going to go back and check that, appreciate the help!