PCEngines APU1D4 and pfSense 2.1.5 Setup



  • Hi all,

    I have run into an installation problem, while trying to install pfSense 2.1.5 on a PC Engines APU1D4 board. I use the Serial console embedded image and I had the serial cable attached. I have prepared the SD card (Kingston 8GB, Sandisk 8GB) using physdiskwrite from the MonoWall project (www.monowall.ch) using

    physdiskwrite -u pfSense-2.1.5-RELEASE-4g-amd64-nanobsd.img.gz
    

    During the write process, no errors were displayed.

    Now when I plug the SD card into the main board and boot it up, I always end up on this screen:

    PC Engines APU BIOS build date: Sep  8 2014
    Total memory 4096 MB
    AMD G-T40E Processor
    CPU MHz=1000
    USB MSC blksize=512 sectors=15659008
    Press F10 key now for boot menu:
    drive 0x000f2ab0: PCHS=0/0/0 translation=lba LCHS=974/255/63 s=15659008
    Booting from Hard Disk...
    
    1  pfSense
    2  pfSense
    
    F6 PXE
    Boot:  1
    \
    

    At this point, the device seems to hang. The firmware I am using is the latest one, 08/09/2014 with "reduced spew level" from [1]. I have upgraded it using the Tinycore Installer provided by PC Engines on their website [1].
    Boot order is set to SD card as a first device.

    Does anyone have an idea where the problem could be?

    I run another PC engines board, the former revision, APU1C4, and a 32GB SD card from SanDisk without any problems…

    Thank you very much,
    André

    [1] http://www.pcengines.ch/apu1d4.htm



  • Have you done this "kern.cam.boot_delay=10000" stuff?
    https://forum.pfsense.org/index.php?topic=59555.msg406438#msg406438



  • The console switches to 9600 at that point, so you are not seeing the rest of the bootup. Change the serial speed to 9600 and reboot the box. You'll have to do the kern.cam.boot_delay=10000 stuff at that point.



  • did you install the pfsense?i'm trying to get it working but with no luck. What modification did you make?



  • Please read the link Phil posted and see if that helps.




Log in to reply