Alix 2c3 w/ 2/8/08 snapshot hangs at DHCP



  • I'm testing the Alix board listed above.  It works fine w/ the 512MB card which came w/ the board & monowall.

    I may have the date on the snapshot wrong, but it was the newest image I could find last night.  I wrote the image to a 1GB card using physdiskwrite under Windows XP.  Pfsense hangs  at DHCP.  I watch it boot via the serial port. (I don't have the router at this location so I can't get  exact error message.)   It doesn't matter if the WAN & LAN devices are plugged in.  It hangs at the same point either way.  Any known issues I should be aware of?

    edited to add: There is no error message.  I don't have the exact message on the screen when it hangs, but IIRC it's "Starting DHCP service" w/ the cursor on the next line.  I have waited over an hour & it never went past that point.



  • Upgrade to the latest snapshot from snapshots.pfsense.org .. Also search before posting. This EXACT question has been posted at least 5 times now.



  • @sullrich:

    Upgrade to the latest snapshot from snapshots.pfsense.org .. Also search before posting. This EXACT question has been posted at least 5 times now.

    Unless I made a mistake I am running the latest snapshot.  I put that info in my subject.  I got this image

    http://snapshots.pfsense.com/FreeBSD6/RELENG_1_2/embedded/pfSense.img.gz

    I did a search before & found this thread
    http://forum.pfsense.org/index.php/topic,6729.135.html

    I'm already running BIOS version .99 & AFAIK I'm running the latest snapshot.  That seems to cover the problems I saw in the threads I read.   I'm sorry if I missed anything, and while I didn't post that I searched the forum, I did search before I posted this.   Did I grab the wrong snapshot?



  • I booted a Alix 2c2 with RC4 last week.  Its upgraded now to RC5 but I had no boot problems at all with BIOS 0.99 and RC4 when I first installed it.  Try RC4 and see if your problem is resolved.  If it does, then you could always do a console upgrade to get the changes/fixes in a current snapshot.



  • Well, I got it to run pfSense.  it was definitely a learning experience.  I have RC4 running on it at this time.  I kept having the problem w/ it hanging at DHCP.  Tried different CF cards, tried writing the images in Linux (Ubuntu 7.10) and Windows.  Nothing fixed it.

    I ended up writing several a couple of cards w/ FreeDOS & DOS 6.22 & copied the most recent BIOS upgrade to them.  FreeDOS didn't have enough free memory to run the BIOS upgrade but DOS 6.22 did.  Once I upgraded the firmware I got pfSense 1.2RC4 to boot & load.  It's running now, and my ipsec VPN tunnel is working.  I'll watch this for a few days & see if things are stable.



  • I had the same problem as jhereg - was able to fix it by loading the 'highmem' driver under freedos.  Flashing the .99 bios to my Alix the worked flawless after that.


Locked