Multi WAN with Asterisk PBX



  • Hello,

    First all, I've been using pfSense for over a year now, and I love the features and stability.

    Here is my scenario.

    Right now, I have a basic setup….1 WAN and 2 LANs (LAN & GUEST).  LAN is for office computers, printers, VOIP PBX etc, and the other LAN which is called GUEST, is for Wifi guest access.

    I have a FreePBX Asterisk server handling our VOIP phones, and its working ok.

    Our WAN connection is a wireless line of sight connections, (we have a static IP) and while it works good most of the time, sometimes it can be a little flaky, which is not ideal for VOIP.

    What I will be doing is adding a DSL WAN connection (with static IP)  to the mix, and here is what I would like to happen.

    Route traffic from the PBX server strictly through the DSL connection.  (However fail over to wireless would be good)

    Route all other traffic from LAN and GUEST through wireless connection (Fail over to DSL would be good.)

    The PBX server has a static IP on the LAN, so I'll need to create some rules for that IP.

    I'm just not sure where to start and if this setup is possible.

    Thanks

    Dan



  • Dan pretty easy for what you want to do. Firsts when you get the DSL connection create a routing group with fail over that way when your DSL goes down all traffic will be routed out of your wireless connection. Then on your LAN rules make sure you have above your any any rule a rule that tells pfsense to send all of your FreePBX traffic out of the DSL connection. The last thing you need to do is go to your NAT Setting -> outbound and change it over to manual. All the rules that you have in place for automatic should be created when you do that so don't worry. Then add a rule that says something like what I have attached. I have created a alias from my Freepbx server so that way if I make a change to my IP network I don't have to change the rules. The rule that you see below is for my plex server but should be very similar to what you want to do. The last thing that I will tell you is that I'm using Pfsense 2.1.5 64bit. I have tried this setup on pfsense 2.2 but the port forwarding rules coming inbound are not working. I'm not sure what is going on with that so I downgraded to the latest stable version. The problem has been reported but I don't think that the developers think it's a issue. I will be testing 2.2 later but needed my setup to work since it's my production home network. Hope this helps.

    ![2014-10-12 06_21_51-pfsense.michaelgatesworld.us - Firewall_ NAT_ Outbound.png](/public/imported_attachments/1/2014-10-12 06_21_51-pfsense.michaelgatesworld.us - Firewall_ NAT_ Outbound.png)
    ![2014-10-12 06_21_51-pfsense.michaelgatesworld.us - Firewall_ NAT_ Outbound.png_thumb](/public/imported_attachments/1/2014-10-12 06_21_51-pfsense.michaelgatesworld.us - Firewall_ NAT_ Outbound.png_thumb)
    ![2014-10-12 06_31_53-pfsense.michaelgatesworld.us - Firewall_ Rules.png](/public/imported_attachments/1/2014-10-12 06_31_53-pfsense.michaelgatesworld.us - Firewall_ Rules.png)
    ![2014-10-12 06_31_53-pfsense.michaelgatesworld.us - Firewall_ Rules.png_thumb](/public/imported_attachments/1/2014-10-12 06_31_53-pfsense.michaelgatesworld.us - Firewall_ Rules.png_thumb)


Log in to reply