Avahi on 2.2



  • Can't seem to get avahi service to start on 2.2 built on Mon Oct 06 03:15:40 CDT 2014, nothing shows up the log.  Anyone manage to get it working?



  • The avahi package was updated to 0.6.31 pkg v1.06 and upgraded to 2.2-BETA (amd64) built on Mon Oct 13 18:39:05 CDT 2014

    Avahi still doesn't start but at least now we get some output in the system log.

    Oct 16 11:37:29 avahi-daemon[41164]: Found user 'avahi' (UID 558) and group 'avahi' (GID 558).
    Oct 16 11:37:29 avahi-daemon[41164]: Successfully dropped root privileges.
    Oct 16 11:37:29 avahi-daemon[41164]: avahi-daemon 0.6.31 starting up.
    Oct 16 11:37:29 avahi-daemon[41164]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
    Oct 16 11:37:29 avahi-daemon[41164]: dbus_bus_get_private(): Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory
    Oct 16 11:37:29 avahi-daemon[41164]: WARNING: Failed to contact D-Bus daemon.
    Oct 16 11:37:29 avahi-daemon[41164]: avahi-daemon 0.6.31 exiting.



  • I get the same error.



  • This can be fixed from a command prompt, with:

    
    mkdir /var/run/dbus
    chown messagebus:messagebus /var/run/dbus
    dbus-daemon --system
    
    

    Then restart Avahi from the Web UI.

    That folder disappears every time 2.2 snapshot is updated, so you have to do the above again whenever you update.



  • works like a charm, tks for that back to streaming across my openvpn tunnel.



  • Works perfectly. Just have to run these commands after every upgrade.


Log in to reply