Shell preference gets overwritten on boot.



  • I configured a user via the Web GUI, I then changed that user's shell to "/usr/local/bin/zsh" via the CLI, but after booting, it defaults to tcsh.

    What mechanism is overriding my shell preference and how can I stop it from doing so?

    Thanks.



  • Are you talking about the shell that is used when the user SSH's in to the box? If so, it is set in the shell script when you select option 8. You can change it in the shell script.



  • yes, the shell that is normally set in /etc/passwd

    Hmmmmm … well ... I just added a .login entry that calls the shell I want (/usr/local/bin/zsh)

    Thanks.



  • There isn't currently a way to choose anything other than the default, what you did there as a work around is fine.



  • @simply:

    yes, the shell that is normally set in /etc/passwd

    Hmmmmm … well ... I just added a .login entry that calls the shell I want (/usr/local/bin/zsh)

    Thanks.

    It's in the shell script that runs the console menu - can't remember the name at the moment (fbegin maybe?) - but tcsh is explicitly called when you pick option 8. You can edit the script and change it to bash.



  • sorry… the script is /etc/rc.initial. Change the shell under option 8 to bash.


Log in to reply