Dell R220 Configuring WAN problems



  • We are using a new Dell R220 with a i386 2.1.5 image.

    If we are using just the two build-in network interfaces bge (Broadcom 5720) everything is working well. However if we add an additional dual port card from Dell (also 5720) we will have a hanging system on Configuring WAN during startup.

    Just to check if these are driver issues we also tried the 2.2 i386 beta op 6 october, and see that we can not configure the WAN port. The machine will however do a full startup.

    Any idea?

    Robert



  • Have you tried the 64-bit version?  You really should be using that if you have hardware that supports it.

    Check the BIOS for any mention of PCI-e power features and turn them off.


  • Netgate Administrator

    Since you are using Broadcom NICs in Dell hardware you should try the tuning options suggested here:
    https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#Broadcom_bge.284.29_Cards

    That advise may be a bit dated now and you aren't running 64bit so I would not exepect nmbclusters to be the issue. Could well be TSO though.

    Steve



  • Thanks for the advices. Sofar the results with 2.2 beta i386:

    I did use the tuning settings
    I did set all power settings to maximum in Bios

    If the expansion card is added: than the existing WAN interface (bge0) is losing its DHCP address. As soon as the card is removed it will gets its DHCP WAN address back again.

    I will reinstall with 64 bit image 2.1.5 and possible 2.2 and report back.

    Thanks,
    Robert


  • Netgate Administrator

    Have you considered that adding further NICs that also use the bge driver could potentially re-arrange the NIC numbering order? When you add the card bge0 may change port.

    Steve



  • Don't use i386 on any 64 bit capable hardware. Guessing it'll more than likely "just work" with amd64, given that's a widely used piece of hardware (but one likely no one runs 32 bit on).


Log in to reply