Squid 3 slow internet problems



  • I have a pfsense 2.1.5 box with multi WAN, and traffic shaping enabled.

    I'm trying to get squid to run, but all the pages I load are slowing down.
    Going from less than 1 to 2 second load times to up to 20 seconds in some cases, especially pages with heavy content.

    I've tried the normal tuning suggestions, but nothing helps.

    Found this in the system logs, but I'm not sure what I'm looking at.

    Oct 8 10:14:55 php: /pkg_edit.php: Reloading Squid for configuration sync
    Oct 8 10:14:55 check_reload_status: Reloading filter
    Oct 8 10:14:55 check_reload_status: Syncing firewall
    Oct 8 10:14:55 check_reload_status: Reloading filter
    Oct 8 10:14:55 php: /pkg_edit.php: The command '/usr/pbi/squid-amd64/sbin/squid -k reconfigure -f /usr/pbi/squid-amd64/etc/squid/squid.conf' returned exit code '1', the output was '2014/10/08 11:14:55| aclParseIpData: unknown netmask '0.87080559676615' in '80.0.33.8/0.87080559676615' FATAL: Bungled squid.conf line 21: acl localnet src 80.0.33.8/0.87080559676615 Squid Cache (Version 3.1.22): Terminated abnormally. CPU Usage: 0.004 seconds = 0.000 user + 0.004 sys Maximum Resident Size: 0 KB Page faults with physical i/o: 0'
    Oct 8 11:14:55 squid: Bungled squid.conf line 21: acl localnet src 80.0.33.8/0.87080559676615
    Oct 8 10:14:55 php: /pkg_edit.php: Reloading Squid for configuration sync
    Oct 8 11:14:31 syslogd: kernel boot file is /boot/kernel/kernel

    Can anyone help please?

    Ricky



  • i face the same problem long loading for some pages

    this link may help
    https://doc.pfsense.org/index.php/Squid_Package_Tuning



  • Thanks Finalcut,

    Unfortunately I've tried all that already with no luck.
    I've got another office running it no problems, though the environment is much simpler.

    Last time i had this problem I put it down to Squid not supporting multi-wan, though as squid monitors the LAN interface I can't see how this is a problem.


Log in to reply