Can you access the web interface on an offline pfsense box?



  • I've installed pfsense to an offline machine.  Is it possible (like with a typical router) to access the web interface of a pfsense box by setting a static IP in the client, then connect via ethernet to the LAN nic on the pfsense box?  I'd like to have the box fully configured before swapping it with the existing router.

    Thanks!



  • Yes, no problem.
    And if the pfSense LAN has DHCP enabled (which is the factory default) then you can just connect a client device directly to the LAN NIC and it will be given an IP address - no need to even mess with giving the client deice a static IP.
    Then browse to the LAN IP and set up everything.



  • I encountered the 38% bug, but got around it by disabling various cpu settings in BIOS.  I then re-enabled those cpu settings in the BIOS and booted up.  Everything is at default (192.168.1.1/24) but when I connect a PC to the LAN port, I can't ping the device (and pfsense can't ping the PC).  I tried auto DHCP and setting a static IP on the client…neither work.  So I can't get into the web interface.  If I set the client to a static IP and launch pfTop, I can see the client's IP show up in the Source column, but at no point am I able to ping back and forth or connect to the web interface.



  • @newpfsenser:

    Everything is at default (192.168.1.1/24) but when I connect a PC to the LAN port, I can't ping the device (and pfsense can't ping the PC).

    Can you try a switch on the LAN port, and connect the PC to the switch?  Or use a cross-over cable between the LAN port and the client PC?  Maybe you have an older NIC that doesn't do auto-cross, and needs a real crossover cable.

    You can also start a shell (Option 8 ), and look at 'ifconfig' output to make sure the interfaces are up.



  • @charliem:

    Can you try a switch on the LAN port, and connect the PC to the switch?  Or use a cross-over cable between the LAN port and the client PC?  Maybe you have an older NIC that doesn't do auto-cross, and needs a real crossover cable.

    You can also start a shell (Option 8 ), and look at 'ifconfig' output to make sure the interfaces are up.

    Tried a switch with the same result.  The web interface doesn't use a non-standard port?  I'm wondering, since IPFire uses port 444 for its web interface.

    ifconfig shows the status of rl1 (LAN) as active and rl0 (WAN) as no carrier.  Just for fun, I plugged the cable into the WAN port and ran ifconfig, and it then showed rl0 as active.

    FYI, same PC, same NICs plugged into the same slots works fine with IPFire and Untangle.  I'm testing these 3 distros, each installed on its own hdd.  For whatever reason, I only have this issue with pfsense.  Maybe it doesn't like my hardware?  It's a newer PC, but I'm using old PCI NICs (Realtek 100Mb).  I know they aren't ideal, but I'm just in test mode, and that is what I had available.  There is a Gigabit onboard NIC that I am not using (it's not configured).

    Thanks for the help!  I'd really like to get pfsense up and running so I can check it out.


  • Netgate Administrator

    This should work pretty much 'out of the box'.
    Try swapping the WAN and LAN NIC assignments or using the on-board Gigabit NIC for LAN.
    When you use DHCP is the client receiving an address?

    Steve



  • @stephenw10:

    This should work pretty much 'out of the box'.
    Try swapping the WAN and LAN NIC assignments or using the on-board Gigabit NIC for LAN.
    When you use DHCP is the client receiving an address?

    Steve

    The machine in question is now in service with IPFire, so I can't test at this time.  However, I tried pfSense on another PC, configured like the first one, and I had no problems accessing the web interface.  At least I'm able to evaluate pfSense now, but there seems to be some hardware compatibility issue with the first system.  If/when it gets pulled from service, I'll give it another try with your suggestion (using onboard Gb for LAN).

    Thanks!


Log in to reply