Dansguardian 2.12.0.3-i386 Will not start



  • I sincerly apologize if this has been answered elsewhere - I looked at everything I could find that ppeared relevant to my case.

    I have pfSense up and running perfectly, I just cannot get dans guardian to start.  I am running a 32-bit system, and I installed the i386 dansguardian packed, but when I do

    "/usr/pbi/dansguardian-i386/etc/rc.d/dansguardian onestart"

    I get the following errors:

    Starting dansguardian.
    Error reading file /usr/pbi/dansguardian-amd64/etc/dansguardian/lists/contentscanners/exceptionvirusmimetypelist: No such file or directory
    Error reading file /usr/pbi/dansguardian-amd64/etc/dansguardian/lists/contentscanners/exceptionvirusmimetypelist: No such file or directory
    Error opening exceptionvirusmimetypelist
    Content scanner plugin init returned error value: -1
    Error loading CS plugins
    Error parsing the dansguardian.conf file or other DansGuardian configuration files
    /usr/pbi/dansguardian-i386/etc/rc.d/dansguardian: WARNING: failed to start dansguardian

    I also try just starting the main exe file in sbin, doesnt work either I get the same error.  Can someone help me find out WHY it is looking for the 64-bit exceptionvirusmimetypelist?

    Yes I checked the obvious and skimmed the config files, perhaps I missed something?

    I have tried various remedies for this to no avail.  I troed to cheat and use a symlink to the dansguardian-i386 equivalent location



  • So I read further down in the forum that the package is broken? will somebody please verify?  I am running a 32 bit distribution.

    Thank you  8)



  • sounds like you are missing blacklists… try downloading them.


Log in to reply