VoIP issue through IPSEC



  • Hello,

    I have the following situation:
    Multiple (4) offices connected through IPSEC VPN. All sites use pfSense firewalls, version 2.1.5.
    Every office has it's own IPSEC connection to another office.

    The IPSEC tunnels are required in order to let the phones (some softphones, other hardware phones) call each other.

    The strange thing is that the 4th office is experiencing one-way audio ONLY when calling the main office.
    The main office can setup calls successfully with other offices, with two-way audio.
    The 4th office is able to successfully perform phone calls with all other offices as well.

    So when the main office calls the 4th office, they experience one-way audio: The 4th office caller doesn't hear anything, while the main office employee hears what the 4th office caller says.
    When the 4th office calls the 3rd or the 2nd office, they don't have any issues.

    The SIP server is located in the main office (SwyxWare server).

    The only thing is that the 4th office uses XS4ALL Fiber connection (50/50 Mbit). The WAN interface at that site is configured with a tagged VLAN (6) and a PPPoE connection to XS4ALL.

    What am I missing here?



  • Either the RTP can't get from main to 4th, or is being misdirected, or the PBX maybe isn't configured correctly with the 4th location's subnet as an internal network. No firewall rules allowing the RTP on IPsec tab at the 4th location is probably the most likely of the possibilities, judging from the solution to similar issues I've worked through with people.



  • At both ends I have allow all rules for IPv4 and IPv6 traffic.
    From the PBX I can ping the phone, and reach it's web interface.

    Didn't test from the clients pc on main office Side yet though. Can try that tomorrow.


Log in to reply