WAN and DHCP not working



  • I'm stumped.  I just setup an old computer to ack as my new router.  I configured the WAN to be dhcp, LAN to be static.

    When I hooked it up to the cable modem, I restarted the cable modem (to recognize the new mac address), hit status->interfaces, told WAN to release and renew.  It went through the process, but returned with 0.0.0.0.

    I then unplugged the cable modem again for longer, rebooted the router, still no DHCP.

    I then changed the WAN to static, entered in the IP, gateway, dns from what the old router had (from DHCP). and that didn't work either.

    I was able to verify the changes with ifconfig in the shell.

    Any ideas on what to look at next?  When I plug my old router in, it works just fine.

    thanks,
    david


  • LAYER 8 Netgate

    Call your cable company?  Clone your old router's WAN MAC address into pfSense WAN?



  • I tried cloning my mac address and that didn't help either. :(



  • For debugging, should I be able to connect my wan to my local lan (with old router hooked up) and then plug a laptop into the new router lan port and get access to the internet?

    There has to be some way to test the new router in this manner.

    thanks


  • LAYER 8 Netgate

    Sure.  Delete the cloned MAC first.



  • If the old router works, it might be worth a look at the old router's settings to see if there's something particular about it's WAN/DHCP/DNS settings.



  • Well, I figured it out.

    I was using a usb ethernet device with the MCS7830 chipset, that I had to load the kernel module to get recognized.  From here:
    https://forum.pfsense.org/index.php?topic=50241.0

    It did recognize it, I could configure it and everything, but it just didn't work.  I pulled an old pci ethernet card out of the junk box and now everything works just fine.

    thanks everyone


Log in to reply