Ntopng error showing in syslog on 2.2 10/10/14



  • Oct 10 17:41:11 ntopng: [HTTPserver.cpp:379] ERROR: Unable to start HTTP server (IPv4) on port 3000
    Oct 10 17:41:11 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoLiteCityv6.dat
    Oct 10 17:41:11 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoLiteCity.dat
    Oct 10 17:41:11 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoIPASNumv6.dat
    Oct 10 17:41:11 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoIPASNum.dat

    not able to use map in ntopng



  • This snippet from the ntopng makefile shows how you can get these files.  I will try to install these by hand in the next few days.

    geoip:
    	@if test -d ~/dat_files ; then \
    	  cp ~/dat_files/* httpdocs/geoip; gunzip -f httpdocs/geoip/*.dat.gz ; \
    	else \
    	  cd httpdocs/geoip; \
    	  wget -nc http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz; \
    	  wget -nc http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz; \
    	  wget -nc http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz; \
    	  wget -nc http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz; \
    	  gunzip -f *.dat.gz ; \
    	fi
    
    


  • Hi!
    I have tried downloading and extracting IP databases, but it still does not work.
    Maybe it is permissions problem?

    Same error on logs:

    Nov 11 21:15:34 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoLiteCityv6.dat
    Nov 11 21:15:34 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoLiteCity.dat
    Nov 11 21:15:34 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoIPASNumv6.dat
    Nov 11 21:15:34 ntopng: [Geolocation.cpp:59] WARNING: Unable to read GeoIP database /usr/local/share/ntopng/httpdocs/geoip/GeoIPASNum.dat



  • Copy the .dat files to /usr/pbi/ntopng-amd64/local/share/ntopng/httpdocs/geoip instead of the path listed in the error message.  Something like:

    pushd  /usr/pbi/ntopng-amd64/local/share/ntopng/httpdocs
    mkdir geoip
    cp -vp /root/*dat ./geoip/
    

    The geoip stuff works for me after that.  Note you will have to do this after every package reinstall or pfSense update.

    I also noticed the two methods for setting the password don't play nice together (ntopng gui 'manage users' vs pfsense 'ntopng settings').  Actually there's a third method too, via the console: http://blog.redbranch.net/2013/12/12/reset-ntopng-admin-password/


Log in to reply