WAN works on DHCP, not on Static IP



  • Hi,

    This is weird.  My WAN works fine if it boots up on DHCP but doesn't work at all if on static IP.  I was concerned at one point that the physical hardware had a problem, but the fact it works fine on DHCP tells me there's nothing wrong there.  The MAC address for the WAN is accepted by the router on DHCP (I do delete the MAC entry from the router when changing back to static IP on pfSense so that it is not being held against the DHCP assigned IP address).  I have other devices (Windows, Android, Linux) connected to the same router as the WAN that also use static IPs without problems, so I don't think it's a hub issue.

    What have I missed?

    (My test of checking if it has worked is to search for the router in the hub's network diagram, and to try accessing the webConfigurator via the WAN IP address via browser on one of the other devices within the 192.168.1.0/24 address range; anti-lockout rule applied on the WAN for the time being).

    pfSense Box
    em0 = WAN –> BT Home Hub 2.0
    em1 = LAN --> GS108T

    Works when: WAN Type = DHCP, all other fields left blank, system rebooted.

    No traffic whatsoever when: WAN Type = Static IPv4, all other fields left blank except: IPv4 Address = 192.168.1.123/32 (tried /24 as well, on a whim), IPv4 Upstream Gateway = GW_WAN (192.168.1.254), system rebooted.

    Any help appreciated.

    Regards,
    Rob.



  • IPv4 Address = 192.168.1.123/32 (tried /24 as well, on a whim), IPv4 Upstream Gateway = GW_WAN (192.168.1.254)

    With /32, 192.168.1.123 will be in a little "subnet" all on its own. You will certainly need to specify /24 so that pfSense WAN and its upstream gateway find each other in the same subnet (192.168.1.0/24)



  • Hi,

    Thanks.  It was 32 by default when I filled in the screen originally, so I left it.  I had wondered if it should be 24, but when I tried it it didn't work.  I just set it back to 24, no joy; rebooted, no luck; rebooted again without any changes, and now it is working without a problem and with the only change being 32 -> 24.

    Weird that it needs rebooting for the changes to take effect, given I can make changes on the LAN side without issue, it makes me think the hub is holding on to duff address data while the link is up.

    Anyway, it appears to be working as expected now.  Thanks again.

    Regards,
    Rob.



  • All those sort of changes (WAN IP address and/or netmask) happen on-the-fly without reboot. So I am not sure what happened there - I guess some confusion between the upstream device and pfSense WAN, who knows! Glad it is working now.


Log in to reply