Installation ALIX APU mSATA SSD not possible



  • Hello,

    installation file:

    http://snapshots.pfsense.org/FreeBSD_releng/10.1/i386/pfSense_HEAD/livecd_installer/pfSense-memstick-serial-2.2-BETA-i386-20141006-0519.img.gz

    I tried to install pfsense 2.2 32-Bit on our Alix APU. I started from the USB stick and after booting pfsense I selected "I" for "install". The installer runs and up to the end there was the question about the kernel to install. When I select "embedded kernel" the installation fails an cannot copy the apropriate kernel. Installation with the standard kernel runs, but after the installation as expected NO serial output.

    Why the install of the selected embedded-kernel do not work"

    Or ist there another way to install 2.2 BETA 32 Bit on the APU?

    Also the other 2.2 memstick-serial images do NOT work.

    Any hints?



  • hi,
    try this suggestion:
    Install freebsd on some usb stick. Download the .img file to inside. Boot from usb in APU, dd command from .img to /dev/daX.
    Boot the new mSata. If after kernel boot, some error occur because of path (ufs:/dev/adaX), just make the procedure (command: ?) to see availables drivers and continue boot. Correct the fstab with new path. That's it.

    Update: mount the /dev/daX after dd command. See in /boot/loader.conf the configuration to serial speed console. This APU if i can remember is 115200. I think pfSense*.img is 38400.



  • But with this method my partition on the mSATA SSD gets only as big as the image is?

    No way to install a version of pFsense 2.2 directly from a live boot to a APU with serial port?

    Why I get the copy error when I try to use the embedded kernel? Is this an installer bug or the live image has no kernel for serial devices?



  • the image size limit the use size in msata.
    For second question, maybe if you open the iso and alter the loader.conf and boot.config in / to see the serial output.
    One thing you can do (is not the right way), is install qemu in freebsd installed in usb stick and running the /dev/da0 like hd and cdrom to the pfsense*.iso and install.
    About the errors, i can't help you. I not work anymore with this apu from pcengines and not have here to simulate the problem and debug. Sorry for that.



  • I'm running pfsense 2.2 beta on APU with a 8GB SD card (I haven't got a mSATA disk) . Since I could not get into the serial console, first I Install 2.1 nanobsd stable firmware from netgate: https://firmware.netgate.com/firmware/, then upgrade to 2.2 smoothly through GUI. I don't know whether it's suitable for you.



  • This was the best tip!

    1. Download pfSense 2.15 USB/memstick serial installer for 32 bits (NOT the nanobsd version)
    2. install this release and select "embedded kernel"
    3. Boot it (9600 baud) and connect with the internet
    4. in the "updater settings" select the address of the new 2.2 release
    5. Invoke automatic update
    6. pfSense boots (115200 baud) with 2.2 AND serial console AND the whole disk partition

    Thanks to all supporters!

    Uwe



  • Hi Uwe,

    I installed 2 APUs with 30GB Kingston mSATA SSDs with the 64bit USB/memstick BETA without any issues.

    I should mention, I upgraded the APU firmware to Build 9/8/2014 (beta, reduced "spew level") beforehand.
    Available here: http://www.pcengines.ch/apu1c.htm



  • @eSpezi: I am facing the same error copying the embedded kernel mentioned above. Which version did you choose exactly? There is memstick and memstick-serial.

    I tried this one: pfSense-memstick-serial-2.2-BETA-amd64-20141106-0359.img.gz

    EDIT: https://redmine.pfsense.org/issues/3982



  • Hi Ben,

    just installed 2 more APUs with the latest memstick-serial-2.2-BETA image yesterday with only one problem.
    1.) Upgraded the APU firmware to the one mentioned in my last post.
    2.) Installed pfS from memstick with option "Easy Install".
    I chose the "Embedded Kernel". After that you will get 2 copy errors, which you can skip. That seems to be no problem - after that the install finished successfully and pfS runs fine.

    I installed 5 APUs that way, 2 already running in production for a month, without any issues so far.
    With the 2.15-Release and older APU firmware I had a hard time to get the mSATA SSDs running…

    Good Luck!
    Harry


  • Rebel Alliance Developer Netgate

    The "embedded" choice error is fixed in current snapshots now. Though there are still some issues (check redmine)