Problem with squid and login systems



  • Hello,

    I have been testing squid 1.2-RC3 for the past week, but I have run into a problem that will prevent me from using it.
    I require using the squid proxy to block access to such sites like pandora.com, myspace.com, youtube.com, etc - because of the high bandwidth usage.

    When I enable the transparent proxy, I encounter a problem in our local intranet where  shortly after logging in, it causes us to be logged out. So I tried to put the URL in the "Do not cache" list, because I though that might be the issue, however it did not help. I searched online for hours and found that you can tell squid not to cache by placing some information in the http headers, which I had our developers do - unfortunately it still did not help.

    Basically, all I want to use squid for is the proxy to block websites. I'm not sure if the caching is the issue or not, but there is some kind of problem with the transparent proxy and our intranet site.

    Does anyone have any tips or suggestions?

    Thank you.



  • Do you have Throttle only specific extensions enabled on the Traffic management tab?



  • No, I believe that is left at default (unchecked)
    I can try turning it on if you think it may help.



  • i think, squid is updated, so you need also an update and then test it again..



  • It was turned on by default on a fresh installation here.  You might double check it.



  • Thank you.
    I will update and double check it and report back.



  • Hi,

    I updated squid, and unchecked the "Thorttle specific extensions" options, and restarted the squid service.
    Unfortunately, the problem still remains. Any other ideas? I will try desperately to get this working.

    Thanks!



  • Are you on RC3?, first i would make an update to a recent build or you can test it with a fresh installation



  • I set up a new machine with 1.2-RC5 and configured it similar to the other one (pretty basic setup) except on a different internet connection. The problem does not appear to be happening through the new machine, so i'm not sure if something fixed it, there was maybe a configuration issue, or its the internet connection.

    I'll keep playing with it…



  • It appears that I was not able to reproduce this, as I put a 1.2 machine into production with squid and the problem is still ocurring. Once I disable the transparent proxy, the problem disappears.

    Any ideas?


Locked