Fresh pfSense Image for vk-t40e2 router



  • Hi guys,

    i was wondering if i can download and flash a plain image for the vk-t40e2 pfsense router. I have already tried to download the official releases but they don't boot on my device…can you help me ?

    thans in advance



  • That is the APU, isn't it? The BIOS serial console runs at 115200, but then the default pfSense image console is 9600.
    With the default pfSense images you have to do kern.cam.boot_delay 10000 stuff to get it to wait for USB to init properly before it tries to see the SD card and boot from it - https://doc.pfsense.org/index.php/Boot_Troubleshooting

    If you don't want to mess with all that by hand, then NetGate has an image pre-built with /boot/loader.conf.local containing kern.cam.boot_delay="10000" and…

    moderator edit: removed link



  • I downloaded this image from the Netgate website ( i bumped into it long time ago ) and then flashed on a SDCard, 8gb denomination :

    moderator edit: removed link to something people should never write out as instructed.

    and after a short time I hear the little tune warning me that the boot has finished and that the router is ready to work. In any case, the DHCP server doesn't work and I can't connect by means of the serial port as well.

    I tried with minicom ranging baud rates from 9600 to 115200 and 8N1 settings but i always have a blank screen on the serial communication…where's the matter ?



  • The images in that folder you linked to say that they are VGA - maybe that is why you have no serial console?
    Since it boots (you hear the happy startup finished sound) it is surprising that you get no DHCP on LAN. I don't know what the interface assignment is in that image, maybe LAN s not on the port that is printed "LAN" on the case?
    Anyway, you might get further with a serial image  ;)



  • I have thought about that but some time ago I installed on a Netgate 7541 a vga image allowing the remote control from serial console as well.

    It seems that this routers is by default shipped with a vga image and not a serial one. By googling around I found this guide :

    http://www.yawarra.com.au/tutorials/how-to-install-pfsense-on-an-apu/

    and altough I flashed a serial image on a SDCard media I still don't get any output ("garbage" included). So I'm starting to think that the serial port could be faulty. I tested it with two different serial to usb converters without any result….

    Regards, Arturo



  • Removed a couple links here, one that was not something to write out in the way instructed, one that won't exist much longer in that location.

    If you need to re-flash any hardware you purchase from us, please get in touch with us via your bundled support and we'll be able to point you to the correct image.


Log in to reply