LCDproc not working with CFA (Crystalfontz) 633 USB LCD



  • Hi guys

    First time posting, just getting aquainted with pfSense in my homelab.

    I have bought a Citrix Branch Repeater box that was decomissioned and have put pfSense on it, and upon installing pfSense (latest x64) can see that it recognises:

    ugen3.2: <crystalfontz> at usbus3
    uftdi0: <crystalfonts cfa633-usb="" lcd=""> on usbus3</crystalfonts></crystalfontz>
    

    Physically in the case I can see that it is indeed connected to the system via a USB daughter board attached to the back of the CFA633 (firmware 1.1, after around firmware 1.5 the 633 no longer requires a daughter board as far as my research shows)

    To try and fix this, as ugen3.2 doesn't show up in the available ports for LCDproc, I followed instructions from this post by mikeisfly: https://forum.pfsense.org/index.php?topic=44034.480 (forgive my lack of knowledge on proper hyperlinking format), then tried replacing "ttyU0" with "ugen3.2" to try and trick it into looking there, but no luck.

    I have found an old guide addressing a similar issue with CF-632/633/634 on FreeBSD in general here http://www.tnpi.net/computing/freebsd/crystalfontz.shtml but also had no luck, as most of the commands in the guide are depreciated and gone.

    The LCD works when plugged into Windows, which has to install the LCD and the usb-serial bridge daughter board separately, so I think it may be an issue where LCDproc believes it is a straight USB connection but should be treating it as serial?

    Any help greatly appreciated.



  • Ok this should help you out. I had to deal with finding a device name for NUT recently. When you plug USB devices in it may display ugenx.x such as you listed. This is not the interface that you need to point to though. I thought this at first as well.

    Go to pfSense & drop to shell (option eight) then su, cd /dev & issue LS command.

    You should see the ugen interfaces in purple font. These are non-selectable interfaces. Don't know the exact reasoning. You should also see stuff listed in blue font with yellow background to it. These are useable interfaces that you can assign. In my case mine are really called cuaUx (where "X" is a number, 0-7 for me).

    ttyUx is sometimes a device interface but not always. As stated mine are cuaUx designation. You will have to check yours. Plug in those values, you may have to try them one at a time & one of them will be your LCD & should start working for you.

    Edit:Look where I told you & see if you see "uftdi0" listed in blue & yellow. I would almost be willing to bet that is the device interface. If not for some reason it should be one of the blue & yellow interfaces listed.



  • lcdproc-0.5.6 pkg v. 0.9.10

    The & was in my config.. not sure if I did while back or was part of a update that I got.  Either way that worked.  But yes you have point since the package points to amd 64 locations that would cause issue with i386 and older versions as I think they have different file structure

    My skills are limited.. Hope someone will help with this.

    And my time is limited also..

    Found Jim-p did that & stuff to the file little while ago
    https://github.com/topper727/pfsense-packages/commit/a890380266da7f589b809701bd3d0e8ac715e82f

    /usr/local/pkg you will see lcdproc.inc file on your 64 bit machine and replace that file with my file you get from link and you will have a 2.2 release 64 bit version working

    Can also use the under diagnostics in PFSENSE UI the "Edit File" and go to /usr/local/pkg/lcdproc.inc and delete the code there all of it and put what you get inside the file you download from me

    https://www.dropbox.com/s/lgo5lyt0tll9uu5/lcdproc.inc?dl=0

    If not know how to do then message me and I can help maybe even remote in and do for you.



  • hey , some know where i can buy a lcd usb ?

    thanks



  • https://www.crystalfontz.com/  I have the 735 version and has nice features and nice display



  • @Topper727:

    https://www.crystalfontz.com/  I have the 735 version and has nice features and nice display

    can you send me link of model 735 ?

    thanks





  • Wow Updated to lcdproc-0.5.7_2 pkg v. 0.9.10 and now my LCD broke sitting at server screen but no clients.. I had to fix it last time what happened this time?