Youtube Dyanamic and Update Caching breaks caching



  • Hi!

    Long time lurker, first time problem.

    Setting up a parent Sibling Proxy (Parent on NAT firewall exposed to outside, Sibling inside no nat) and during testing I noticed I get no cache hits, and the Hard Disk usage of /var/squid/cache does not change. I added an extra hard disk and it's usage doesn't change either. Tried squid3-dev and no change, but when downgrade to squid (2-ish?) it works!  I even created a new Virtual Machine (This instance of pfsense is virtualized on esxi 5.5, and is a PAIN to make work), but problem still exists.

    I had Dynamic and Update Caching enabled for windows updates and youtube right out on first configs but squid 2-ish has no dynamic caching but worked out of box. So, this got me thinking, I enabled dynamic cahcing but for windows updates only, cleared /var/squid/cache and squid -z  it and now I get hits and hard disk usage goes up! whoa… nice :D spend a week bashing my head on this... now onto the parent/sibling thing.

    TL;DR: Youtube dynamic caching on squid 3 or squid3-dev is broke, yo!


Log in to reply