Atheros wireless card - 2 interfaces both only work 802.11g



  • I have a build with an Atheros AR9287 (or AR5B97) pci-e card that I was hoping I could get to work at 802.11n speed in version 2.2. Unfortunately, it shows with two interfaces (ath0_wlan0 and ath0_wlan1) and neither of them will work if I select a speed (on the interface screen) greater than 802.11g. If I select 802.11n, the interface will not come up. I've also confirmed that it only gets G speeds when I select 802.11g.

    Couple questions:
    1.) Why does it show two interfaces (ath0_wlan0 and ath0_wlan1)?
    2.) Why can't I get 802.11 speed on this card? Is it a driver issue?

    Thanks!



  • I tried a recent 2.2 build with an AR5B95. It only created one interface by default. I could go to interfaces, assign and create a second one. If you don't want a second virtual AP, delete it. Maybe it was a bug in the build you had. Mine came up fine under 'ng' and I was able to connect to it with an n client. I did not test throughput.
    I think I used this image: pfSense-2.2-BETA-2g-i386-nanobsd-20141009-1505.img.gz



  • Interesting… This is the third build I've tried and it always shows two interfaces. and... like I said it will only let me select 802.11g as the speed. If I select 802.11n, the interfaces wont come up.



  • Just bumping…

    Anyone have any ideas why this card (Atheros AR9287/AR5B97) only works in G mode? If not, can anyone tell me cards that is tested to work in 2.2 in N mode?



  • Mine was just a generic 9285/AR5B95 from a laptop.



  • Hate to ask, but based on your prior post I wasn't sure - is there any way you can confirm getting "N" speed out of it? I just don't want to buy another one and have it not work… Also, did you try turning on WPA2 encryption?  Thanks!



  • Can't confirm speed at the moment. That box is not connected to the Internet, and it's back running 2.1.5 for the time being. Sorry.


  • Netgate Administrator

    Did you try removing the second virtual interface? It could be that it won't allow you switch radio modes when you have a multiple VAPs assigned or it's trying to operate on the virtual interface rather than the real hardware.

    Steve



  • Hmmm… Not sure I fully understand what you are suggesting...

    How would I "remove the second virtual interface"? There are two interfaces - ath0_wlan0 and ath0_wlan1 - and it seems that they are auto-detected by FreeBSD at bootup. I have tried not setting one of them up in pfSense (on the interfaces menu) but that doesn't make any difference. In other words, even if I only set one of them up in pfSense, I still only get "G" speeds out of the configured interface...



  • Go into interfaces, assign and click the X next to the second wireless interface.



  • @dotdash:

    Go into interfaces, assign and click the X next to the second wireless interface.

    Yep… that's what I've done. I've also just tried not even setting it up in pfSense at all. Of course, even if I don't create an interface for it (say for example and opt1 interface associated with ath0_wlan1), it still shows as an option to pick in the dropdown list of interfaces on that page (for "opt" whatever).



  • Did you flip to the wireless tab under assign interfaces?


  • Netgate Administrator

    I may have misunderstood the situation. Is this a dual radio card perhaps?
    I have seen similar problems with trying to apply some driver specific config to a virtual interface. A vlan instead of it's parent interface for example.

    Steve



  • @stephenw10:

    I may have misunderstood the situation. Is this a dual radio card perhaps?
    I have seen similar problems with trying to apply some driver specific config to a virtual interface. A vlan instead of it's parent interface for example.

    Steve

    Yea… that was my first thought as well Steve... not sure if it is dual radio (or dual range which I guess ends up being two radios) or not. But I was asking if that is how a dual card would show up? Interfaces listed as I described? So, assuming you had two atheros based cards with each having two radios, would you end up with ath0_wlan0, ath0_wlan1, (for the first card) and ath1_wlan0, ath1_wlan1 (for the second card)?



  • I doubt it's a dual radio card. Maybe dual band. I've tried an Atheros dual band miniPCI card under 2.2, and it showed up under assign interfaces as 'ath0'. I expect this is the 'friendly name' because if you create a second vap, it comes up as ath0_wlan1. IIRC, you can't use the raw interface (athx) under FreeBSD versions >8, so to use the interface, you have to create the inital vap (ath0_wlan).
    Anyway, In my tests, I just got one interface unless I manually added a second one. The dual band card just allowed me to select 5GHz channels. I've only tried Atheros cards, apart from a run dongle, which I found out still doesn't have an n-capable driver under 10. (Mine was a 2800, errata suggests the 2700 chips work at n speed.)



  • @rjcrowder:

    Anyone have any ideas why this card (Atheros AR9287/AR5B97) only works in G mode? If not, can anyone tell me cards that is tested to work in 2.2 in N mode?

    I would have hoped (probably like many others) that 2.2 Atheros support would look something like this:

    https://wiki.freebsd.org/dev/ath_hal(4)/HardwareSupport

    In fact, this is one of the biggest drawcards of 2.2 for me. If you're having issues with a specific card, maybe search some FreeBSD forum links and see if its been discussed. I have AR5BXB92, which is just a AR9280, and I was really hoping it would support N speeds.



  • As best I can figure it out… here's the deal.

    1.) Having two interfaces was my fault. Apparently I had erroneously created a clone on the "wireless" tab. I've now deleted it.
    2.) I have ath0 working and I am able to wirelessly connect. However, the interface will NOT come up if I select 802.11ng as the "standard". It will only start if I select 802.11g.


  • Netgate Administrator

    Any errors in the system log? Or other evidence?

    Steve



  • Nothing under "wireless"… grepping dmesg for "ath" gives...

    [2.2-BETA][root@pfSense.localdomain]/var/log: dmesg | grep ath
    ath0: <atheros 9287="">mem 0xf7d00000-0xf7d0ffff irq 18 at device 0.0 on pci3
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    ath0_wlan0: promiscuous mode enabled
    ath0_wlan0: promiscuous mode disabled
    ath0_wlan0: promiscuous mode enabled
    ath0: <atheros 9287="">mem 0xf7d00000-0xf7d0ffff irq 18 at device 0.0 on pci3
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    ath0_wlan0: promiscuous mode enabled
    ath0: <atheros 9287="">mem 0xf7d00000-0xf7d0ffff irq 18 at device 0.0 on pci3
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    ath0_wlan0: promiscuous mode enabled
    ath0: <atheros 9287="">mem 0xf7d00000-0xf7d0ffff irq 18 at device 0.0 on pci3
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    wlan0: changing name to 'ath0_wlan0'
    ath0_wlan0: promiscuous mode enabled
    ath0: <atheros 9287="">mem 0xf7d00000-0xf7d0ffff irq 18 at device 0.0 on pci3
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    wlan0: changing name to 'ath0_wlan0'
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_reset: concurrent reset! Danger!
    ath0_wlan0: promiscuous mode enabled
    ath0: ath_reset_grablock: didn't finish after 10 iterations
    ath0: ath_reset_grablock: warning, recursive reset path!
    ath0: ath_chan_set: concurrent reset! Danger!
    ath0: <atheros 9287="">mem 0xf7d00000-0xf7d0ffff irq 18 at device 0.0 on pci3
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0
    wlan0: changing name to 'ath0_wlan0'
    ath0_wlan0: promiscuous mode enabled</atheros></atheros></atheros></atheros></atheros></atheros> 
    

    Don't see anything anywhere else…



  • It's a dual band card. Did you try setting it for na instead of ng?



  • That's not an option… I've attached a screen shot.

    ![Screenshot from 2014-10-22 11:00:35.png](/public/imported_attachments/1/Screenshot from 2014-10-22 11:00:35.png)
    ![Screenshot from 2014-10-22 11:00:35.png_thumb](/public/imported_attachments/1/Screenshot from 2014-10-22 11:00:35.png_thumb)



  • UPDATE…. if I select a channel (don't use the "Auto" channel select) the interface will start with  802.11ng selected.

    I'm still not sure it is actually getting N speed - but I'm going to work on confirming.



  • OK More info… Per previous, the card comes up with 802.11ng as the "standard" as long as I manually select a channel.

    However, I've tried changing about every setting I can think of (including disabling security), but the card refuses to accept Wireless N connections. When I get connected, the link speed is always 54mbps and the actual throughput is always something lower. In addition, if I set the "minimum wireless standard" (setting a little further down the screen) to 802.11n, then the card refuses all connections. Seems that the card is only setup to accept a "G" connection! Driver issue?

    BTW... this is what ifconfig shows...

    ath0_wlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    ether 18:f4:6a:32:be:c7
    inet6 fe80::1af4:6aff:fe32:bec7%ath0_wlan0 prefixlen 64 scopeid 0x8
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
    ssid pfsense channel 11 (2462 MHz 11g ht/40-) bssid 18:f4:6a:32:be:c7
    regdomain FCC country US indoor ecm authmode WPA2/802.11i
    privacy MIXED deftxkey 2 AES-CCM 2:128-bit txpower 30 scanvalid 60
    protmode OFF ampdulimit 64k ampdudensity 8 shortgi burst -apbridge
    dtimperiod 1 -dfs</hostap></performnud,auto_linklocal></up,broadcast,running,promisc,simplex,multicast>



  • My 9285 also fails when channel is set to auto.
    If I set mine to minimum standard n, I can still connect from a Windows laptop. The laptop shows an n connection.
    I'm getting some errors in the logs- perhaps only when I change a setting and it reloads the interface…
    kernel: ath0: ath_reset_grablock: didn't finish after 10 iterations
    kernel: ath0: ath_reset_grablock: warning, recursive reset path!
    kernel: ath0: ath_chan_set: concurrent reset! Danger!

    But it seems to be working…



  • If you set the "minimum wireless standard" to 'N' - can you still connect?



  • Yes.



  • Hello,

    I am a SE for a wireless company and the 802.11n spec states that if using any authentication method other than WPA2 will result in a max connection speed of 54M. A few responses ago someone asked if you are using WPA2? Has this been checked? Just a thought.


  • Netgate Administrator

    Are you seeing this?

    @https://wiki.freebsd.org/dev/ath(4)/80211n:

    "ifconfig -v wlan0 list channel" should show 802.11n channels "ht"

    Steve



  • Apparently not… this is the output...

    [2.2-BETA][root@pfSense.localdomain]/root: ifconfig -v ath0_wlan0 list channel
    Channel   1 : 2412      MHz 11b          Channel   6 : 2437      MHz 11g ht/40+   
    Channel   1 : 2412      MHz 11g          Channel   6 : 2437      MHz 11g ht/40-   
    Channel   1 : 2412      MHz 11g ht/20    Channel   7 : 2442      MHz 11b          
    Channel   1 : 2412      MHz 11g ht/40+   Channel   7 : 2442      MHz 11g          
    Channel   2 : 2417      MHz 11b          Channel   7 : 2442      MHz 11g ht/20    
    Channel   2 : 2417      MHz 11g          Channel   7 : 2442      MHz 11g ht/40+   
    Channel   2 : 2417      MHz 11g ht/20    Channel   7 : 2442      MHz 11g ht/40-   
    Channel   2 : 2417      MHz 11g ht/40+   Channel   8 : 2447      MHz 11b          
    Channel   3 : 2422      MHz 11b          Channel   8 : 2447      MHz 11g          
    Channel   3 : 2422      MHz 11g          Channel   8 : 2447      MHz 11g ht/20    
    Channel   3 : 2422      MHz 11g ht/20    Channel   8 : 2447      MHz 11g ht/40-   
    Channel   3 : 2422      MHz 11g ht/40+   Channel   9 : 2452      MHz 11b          
    Channel   4 : 2427      MHz 11b          Channel   9 : 2452      MHz 11g          
    Channel   4 : 2427      MHz 11g          Channel   9 : 2452      MHz 11g ht/20    
    Channel   4 : 2427      MHz 11g ht/20    Channel   9 : 2452      MHz 11g ht/40-   
    Channel   4 : 2427      MHz 11g ht/40+   Channel  10 : 2457      MHz 11b          
    Channel   5 : 2432      MHz 11b          Channel  10 : 2457      MHz 11g          
    Channel   5 : 2432      MHz 11g          Channel  10 : 2457      MHz 11g ht/20    
    Channel   5 : 2432      MHz 11g ht/20    Channel  10 : 2457      MHz 11g ht/40-   
    Channel   5 : 2432      MHz 11g ht/40+   Channel  11 : 2462      MHz 11b          
    Channel   5 : 2432      MHz 11g ht/40-   Channel  11 : 2462      MHz 11g          
    Channel   6 : 2437      MHz 11b          Channel  11 : 2462      MHz 11g ht/20    
    Channel   6 : 2437      MHz 11g          Channel  11 : 2462      MHz 11g ht/40-   
    Channel   6 : 2437      MHz 11g ht/20    
    
    

    and per the other post… yes I have everything setup for WPA2.


  • Netgate Administrator

    Looks like you are seeing 'ht' channels. No 5GHz channels though. Not really sure what you should be seeing though, I don't have a card to test.

    Steve



  • OK… since I can get a new card for $5-$6 on eBay, it's about time to give up...

    From what I've been able to google, it appears that both the Intel 5100 or Intel Centrino 6230 should work. Can anyone confirm one of them working at 802.11n speed under 2.2?



  • Unless something has changed, you can't run Intel cards in AP mode…
    Edit- Here is the list from 2.1
    https://docs.google.com/spreadsheet/ccc?key=0AojFUXcbH0ROdHgwYkFHbkRUdV9hVWljVWl5SXkxbFE&hl=en#gid=1

    Basically, Atheros, RaLink, or Marvell.


  • Netgate Administrator

    Yep. Looks like it's the same in 2.2.
    @https://www.freebsd.org/cgi/man.cgi?query=iwn&apropos=0&sektion=0&manpath=FreeBSD+10.1-RELEASE&arch=default&format=html:

    iwn supports station and monitor mode operation.

    Stick with Atheros. At this point it seems by far the best supported wifi hardware in FreeBSD.

    Steve