Athlon 5350 + Asus AM1I-A + powerd = reboots



  • When I configured powerd to be used with my Athlon 5350 (did some other config in the same time) the box started rebooting all the time. I got "hwpstate0: freq not set" errors before rebooting. An easy query on Google showed me that this is an error related to powerd. When I disabled powerd the reboots were gone.

    Just sharing this for anyone experiencing this problem :)



  • Not too surprised that it didn't work for you! I have yet to see 'powerd' to work properly on any of my laptops, old or new!

    I usually get the impression that it works, cause it doesn't crash or reboot my machines.
    But, I always end up by finding some error messages in the log files indicating that my hardware is this or that, meaning incompatible.
    And obviously it doesn't do any good either.
    I can't understand why the software module would even try to run on so called "incompatible" hardware.
    It's most likely some lousy code that nobody bothered to fix because probably not too many people care about running FreeBSD or pfSense on a laptop class machine. I once tried to figure out the source code, I admit it was above my head, but not because of its sophistication or elegance  ::)

    Now, if you want to see it properly run, put PC-BSD on your laptop and check it out. Somehow, somewhere, someone fixed it, beautified it and actually made it work. But that is irrelevant to pfSense, isn't it ?!

    Sorry, I am not saying anything really useful…

    Halea



  • are you sure you really need powerd?

    I get powerd error during POST with my main PC (FX-8350) which is true, based on older Piledriver architecture but after plugging wattmeter into a wall socket, it looks like CPU is performing frequency throttling just fine while running FreeBSD10-RELEASE. CPU clock rates seem to be changing appropriately too.

    I too am very interested about the Athlon 5350 and planning for ECC ram and AM1M-A board. Should nearly twice cut the energy usage compared to current router (~50W)



  • Hey,
    i have the same Problem with my AMD 5350.
    The Mainboards works with an dc Power Supply but still needs 25 watts in idle.
    i also found the powerd feature.
    If i enable the powerd feature, the pc reboots the hole time after 10 to 15 seconds.
    In my Position, it wasen t possible to get on the Web interface or the consol.

    Could that be a bug with the energy feature of the cpu?

    Greetings



  • Could that be a bug with the energy feature of the cpu?

    It is perhaps more CPU tended then might think about. So if you want to go on the safe side
    use a Intel CPU and Intel LAN Ports or NICs. It is not the brand but more the development of
    the whole pfSense that this things are more explored and tested or more and better driver supported.



  • update the bios to the latest one

    what lan cards are you using?

    if all else fails, install esxi or hyper v server and run it inside a vm



  • @pwnd28:

    i have the same Problem with my AMD 5350.
    If i enable the powerd feature, the pc reboots the hole time after 10 to 15 seconds.

    Could anyone please let me know if this is a wide spread issue with the AMD 5350 and powerd not working?

    I am looking at a new build but if this is a wide spread issue I will go another option.



  • @Jas:

    @pwnd28:

    i have the same Problem with my AMD 5350.
    If i enable the powerd feature, the pc reboots the hole time after 10 to 15 seconds.

    Could anyone please let me know if this is a wide spread issue with the AMD 5350 and powerd not working?

    I am looking at a new build but if this is a wide spread issue I will go another option.

    Apparently I thought someone else answered this long ago.

    For almost a year and half I have found using the AMD 5350 AM1 platform a decent solution and have been using a number of them for some time.  So let's lay this misconception to rest…

    SIMPLE ANSWER: NO - using powerd was never really an issue on the AM1 platform if people searched for the right things.

    Detailed Answer:

    The AM1 platform had a known issue with FreeBSD since 2014:

    https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=189267

    Work arounds: (based on the ticket above)

    1. for pfSense 2.2.x:

    add "hint.acpi_throttle.0.disabled=1" to your /boot/loader.conf file as the FreeBSD version used in the 2.2.x releases did not include the patch from above

    once this is added and your box rebooted, powerd works without reboots but the freq levels shift and the lowest minimum starts at 800mhz.  IMHO I believe it makes pfsense generally more responsive then having your lowest state at 100mhz.

    2. for pfSense 2.3:

    throttling is disabled by default since this new pfsense version uses a more recent FreeBSD-Release (10.3) which took in the committed FreeBSD patch from the ticket above.

    Kill-a-watt meter readings, with powerd...

    System: AMD 5350 + Gigabyte MicroATX + 1 x DDR3 + Dual Intel Pro/1000  + Atheros AR9380 x 2  + SSD + PSU (Pico or 80+ ATX)

    Idle average power: 15 watts

    A side bonus is since most AM1 processors have AES-NI, some of the benchmarks I ran with it enabled give a decent boost to certain encryption based tasks (openvpn and ssl).


Log in to reply