WAN is half-duplex while LAN is full, not sure why



  • I just installed and set up pfSense and noticed that on the Interfaces window it shows that my WAN is half-duplex while my LAN is full. Picture: . Now I'm not sure why this is..

    I have cable internet and my pfSense box is connected directly to my cable modem. My WAN device is a USB Network adapter, but it is supposed to be full duplex. Here is the item: http://www.amazon.com/TRENDnet-USB-100Mbps-Adapter-TU-ET100C/dp/B0000CDZ82/ref=sr_1_1?ie=UTF8&qid=1413682675&sr=8-1&keywords=trendnet+tu-et100c

    Why would it be set to half duplex? The only thing I can think is that the cable might be defective though it is brand new… otherwise it's a configuration issue, but I haven't touched anything with that yet..



  • When two 100/Full devices connect to each other, the have a "conversation" to determine capabilities. They will attempt to link at the fast speed and fall back to the slow one. Once the speed is set, one device will switch into full duplex mode and attempt to communicate with the other device using FD. If the two devices can't establish a talk/listen communication, they fall back to half duplex.

    Cable modems are almost always Auto-Detect/Auto-Sense. So, either your USB NIC isn't set to Auto/Auto, or there's a problem. You can try forcing it to 100/Full and see what happens with a speed test. If you start seeing a lot of retransmissions, you have an issue with the duplex.



  • @ember1205:

    When two 100/Full devices connect to each other, the have a "conversation" to determine capabilities. They will attempt to link at the fast speed and fall back to the slow one. Once the speed is set, one device will switch into full duplex mode and attempt to communicate with the other device using FD. If the two devices can't establish a talk/listen communication, they fall back to half duplex.

    Cable modems are almost always Auto-Detect/Auto-Sense. So, either your USB NIC isn't set to Auto/Auto, or there's a problem. You can try forcing it to 100/Full and see what happens with a speed test. If you start seeing a lot of retransmissions, you have an issue with the duplex.

    Yeah, I just tried forcing my USB Ethernet adapter (WAN device) to run full duplex via the pfSense speed settings and that really screwed things up for a while. I had to restarted several times and eventually just hooked my Linksys back up directly to the modem… even then it took a while as I had to restart my modem a few times.. eventually I got connected back to my ISP.

    So either it's my USB Ethernet adapter that is not working at full-duplex (even though it is supposed to be able to do that) or my cable modem is not able to run full duplex, I assume..



  • Find out how your modem's Ethernet port is configured. It sounds like it's forced to 100 Mb full duplex, while your end is on auto, leaving you with a duplex mismatch.

    Never force speed or duplex unless you can do so identically on both devices.



  • @dave247:

    @ember1205:

    When two 100/Full devices connect to each other, the have a "conversation" to determine capabilities. They will attempt to link at the fast speed and fall back to the slow one. Once the speed is set, one device will switch into full duplex mode and attempt to communicate with the other device using FD. If the two devices can't establish a talk/listen communication, they fall back to half duplex.

    Cable modems are almost always Auto-Detect/Auto-Sense. So, either your USB NIC isn't set to Auto/Auto, or there's a problem. You can try forcing it to 100/Full and see what happens with a speed test. If you start seeing a lot of retransmissions, you have an issue with the duplex.

    Yeah, I just tried forcing my USB Ethernet adapter (WAN device) to run full duplex via the pfSense speed settings and that really screwed things up for a while. I had to restarted several times and eventually just hooked my Linksys back up directly to the modem… even then it took a while as I had to restart my modem a few times.. eventually I got connected back to my ISP.

    So either it's my USB Ethernet adapter that is not working at full-duplex (even though it is supposed to be able to do that) or my cable modem is not able to run full duplex, I assume..

    Along the lines of what CMB was referring to… If you force one side of a connection, you're going to have all kinds of issues. Once you force the link on one side to FD, it no longer participates in the "attempt" to switch to FD that's coordinated with the other side and that other side will fall back to HD. When that happens, your performance goes down the tubes as a result of a ton of retransmissions.

    It sounds like you've determined that the modem is NOT fixed to FD. Is there a status page for the modem that you can open? It would be useful to understand what IT is sensing from the connection setup when the computer is in FD.



  • Not solved yet, but I just finished installing pfSense onto another system as a virtual machine with a mainboard nic and a nic card, both of which I know can run full duplex. I got everything set up and now I see that both of my connections are running FD. So that's good to know. My next step will be to connect pfSense directly to my modem and see if it remains FD or drops to HD. I won't be able to do that for a few days as I am going out of town. So if it doesn't work I may be back.

    Also worth mentioning is that my ISP is Charter and a year or so ago they issued mandatory cable modems for subscribers. So I currently can't access my cable modem's settings right now and I'm hoping if I call customer service that they will give me the username and password. However, I have a bad feeling that they wont.


  • Netgate

    They don't need to give you access, but they do need to be able to tell you definitively how the ethernet interface is configured.



  • @Derelict:

    They don't need to give you access, but they do need to be able to tell you definitively how the ethernet interface is configured.

    You'd like to think so, but I don't know that they "need" to tell you this. It should suffice that all modems should be configured the same, and AUTO/AUTO would be the most intelligent setting for them to choose for support purposes. Unless the modem had previously been fixed to 100/Half for some reason, I would expect it to be AUTO/AUTO.



  • Assuming you've probably tried another network cable, if not, do that.

    If your ISP is being less than helpful, you could try plugging some other device into your cable modem. See what it ends up with. If it also ends up at 100 half, then there's a good chance the duplex is forced on the modem, or the modem is bad.