VIA EPIA SN10000EG w/ VT6130 Gigabit Controller

  • I bought this board for friend of mine to make small router box instead of a 15lb steel case monster. It met all the requirements I was looking for, dual Lan, CF mount onboard, passively cooled and sata if needed. Well he did a HDD install of Pfsense to a 266x 4gb CF card, and found that the Gigabit controller didn't work. Link light on, but 0 connectivity. So we booted a live Ubuntu cd to diagnose further. Gigabit controller worked without a problem. Realizing this, I checked the hardware compatibility list. The VT6130 is not in the list. But pfsense found it as nic? Using the wrong driver perhaps? Is there any hope that there is work around? or FreeBSD will soon release a driver that supports the VT6130. Right now we're working with smoothwall has not problems with the Gigabit controller. But we prefer pfsense.

  • Which version are you using? If you still test with 1.0.1 please get the latest 1.2RC5 snapshot and retest. Another thing to note is that you might need crossovercables depending on the opposite end of the connection (Switch, Client, AutoMDX or not). I have seen some cards doing autoMDX on the one OS but not doing this on another OS, so the one OW needed a crossovercable where the other OS used autoMDX and a straight cable worked. I guess this depends on the drivers implementation I suspect. SO you see the nics listed as interfaces? Maybe it's really just a cable issue then.

  • We ran 1.2 RC3 on it. I'll test RC5 snapshot and some different cables this weekend and report back. If it really is a manner of a crossover cable vs patch, I will be amazed. Is testing with a live CD just as good as HDD install?

  • There is no difference between testing with the livecd or an hdd install if you just want to find out if the hardware works or not. The only real difference is that you don't have package support and have to externally save your configuration (usb-thumbdrive or floppy) to not lose your config on reboot.

  • I had my friend try the crossover cable trick and same problem. He also tried a FreeBSD Live CD. It didn't even detect the gigabit controller. So I guess we will have to wait till FreeBSD supports this device. I'm not a Linux/FreeBSD guru but if i find someone with a FreeBSD driver for it. How would I integrate it with pfSense.

  • Try enabling MSI support to it.

    I do not recall the loader.conf knob now but try searching in google.

  • @ermal:

    Try enabling MSI support to it.

    I do not recall the loader.conf knob now but try searching in google.

    MSI first appeared in 6.3.  We use 6.2.

  • Well we figured it out. "Disable Hardware Checksum Offloading" fixed it. The gigabit controller now works perfectly. Didn't know the option existed.

  • Do you get Gigabit speeds out of it?

Log in to reply