Pfsense 2.1.5 to 2.2 experience



  • I thought I would give 2.2 a try so I upgraded my 2.1.5 (64bit).  I currently run squid 3 + squidguard + snort on a vmware workstation machine.
    Update went fine except for squid / squidguard would fail.  I unistalled 3 as per the forum messages with issues and tried installing v2.  Squid worked, but squidguard would not start.  I tried uninstalling both and starting from scratch but that did not help either.
      So my conclusion seems to be that I can't get any version of squid/squidguard running.  It could possibly by my configuration, but that makes an upgrade not possible for me.
      I also found lots of errors on openvmware package.  It seemed to install, but I got kernel messages about vmemm in the console.
      So back to 2.1.5 by restoring the image :)

    I'll try again in a few weeks, and this time I'll get some more detailed results and post the error messages.  It just seems 2.2 is not as seamless on the packages as 2.1.x was.  It's like pre 2.0 on the package compatibility.

    Maybe the non-working 2.2 packages should not be flagged as working on 2.2???  We know squid 3 is not working at this time and it should be flagged until it's running.

    a.r.



  • Anyone manage to get any version of squid to work with squidguard?

    Just wondering if my failure with squidguard has to do with my settings, or if everyone has squidguard broken?



  • Just to point you at another direction. I started running Squid squid 3.4.x series on a separate VM using ESXI, then using wpad to point the clients to Squid. This way you have an up-to-date Squid package. I use pfBlocker and Suricata to block inappropriate/malware sites since Squidguard does not seem to be maintained any longer. This does the same thing but running updated packages.. VERY HAPPY with this setup.



  • Honestly I am just using squidguard to filter adds.  It does a decent job and makes it seamless to users.

    I see squidguard is not being maintained also.  Hopefully since it's not working, the devs will remove it as available in 2.2.  Something is broken in the packages to me if they are flagged as compatible with 2.2 when so many are not working at all.

    Dansguardian is the only alternative I see for squidguard.    Anyone test our dansguardian with the older 2.X squid and see if it works?

    2.2 at this point is not ready for prime time if the main packages are falling apart.