• Pessoal, eu estou começando a usar o pfsense e estou com dificuldade para fazer a seguinte regra:

    iptables -t nat -A POSTROUTING -s 192.168.1.0/24  -d 100.182.12.0/24 -j SNAT –to-source 10.0.0.1

    De acordo com alguns tópicos que li teria que habilitar o NAT outbound no pfsense. Mas em Firewall >> Nat >> Saida quando marco qualquer uma das opções "Geração automática das regras de outbound NAT" "Geração manual das regras de outbound NAT" elas não ficam marcadas.

    Como teria que fazer para determinar o IP de saída para algumas máquinas na rede?


  • isso que voce quer é uma regra de LAN e nao um NAT, crie um alias com os ips que precisa, depois vá em firewall, Rules, LAN, crie uma nova regra, coloque o protocolo que precisa, em Source use o alias criado, se precisar coloque as portas, ou deixe any, em destination deixe any, depois na parte  Advanced features, clique em gateway e selecione o gateway (ip de saida) que voce precisa


  • Lucas,

    Eu quero o seguinte: Se o destino for o IP válido 10.20.179.184 ele tem que sair com o IP 10.238.100.106 que também é válido.

    iptables -t nat -A POSTROUTING -s 192.168.1.0/24  -d 10.20.179.184  -j SNAT –to-source 10.238.100.106

    Essa regra é para acessar a VPN de um cliente.


  • creio ser a mesma coisa, apenas mude o destination de any para o ip de destino, e coloque a regra antes da de proxy se tiver, assim, se a origem for ip xxx com destino ao ip yyyy vai usar o gateway zzzz, pelo menos eu uso dessa forma, nao sei se existe como configurar diferente.. voce pode ir em System, Routing e adicionar uma nova interface de gateway, no seu caso a vpn

    voce pode também procurar como converte a regra iptables para ipfw e fazer manualmente


  • eu criei outro gw e criei a regra:

    IPv4 TCP LAN net * ALIAS_DST * GW_VPN nenhum

    Quando tento fazer um telnet em uma porta que está liberada e acompanho pelo tcpdump a origem continua sendo o meu IP de saída para a internet.
    Eu tenho só um link para a internet, e o ip 10.238.100.106 tem que ser o IP de origem quando este pacote chegar no IP 10.20.179.184.
    Será que estou analisando a saída do tcpdump errada?

    Saída tcpdump:```

    11:44:47.623653 IP meu_ip_público.19981 > 10.20.179.184.ncube-lm: Flags [s], seq 3715761636, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
    11:44:50.624105 IP meu_ip_público.19981 > 10.20.179.184.ncube-lm: Flags [s], seq 3715761636, win 8192, options [mss 1460,nop,wscale 8,nop,nop,sackOK], length 0
    11:44:56.624411 IP meu_ip_público.19981 > 10.20.179.184.ncube-lm: Flags [s], seq 3715761636, win 8192, options [mss 1460,nop,nop,sackOK], length 0

    O IP de origem deveria ser 10.238.100.106.[/s][/s][/s]


  • normalmente é preciso limpar o table states quando se faz esse tipo de regra.. nao necessário, mais pode dar problema..


  • Tm estou com esse problema de marcar a opção "Geração manual das regras de outbound NAT" e ela não fica marcada. Sempre volta para opção "Automática". Alguém sabe como solucionar? Ou se é algum bug de versão?


  • @helciopenha:

    Alguém sabe como solucionar?

    Voltando seu pfsense para inglês.

    Esta usando o pfsense nativo ou alguma ferramenta pseudo pfsense?


  • @marcelloc:

    Esta usando o pfsense nativo ou alguma ferramenta pseudo pfsense?

    Estou usando o PfSense Versão 2.1.5-Release (ad64) em português mesmo. Irei tentar mudar para inglês e testar.

    Obrigado!


  • A regra que vc precisa é em outbound NAT sim, a grosso modo, os parâmetros são basicamente os mesmos do iptables, o que muda é o  -j SNAT –to-source 10.0.0.1 que na tela do Outbound NAT é NAT Address.