Port Forward seems not working. Displays Pfsense login screen



  • Hi!

    I am trying to port forward http port to my webserver but I can't make it work. When i try to access my WAN IP from external network, it displays the pfsense login screen.

    I followed these:

    but no avail.

    Always shows me the login screen. I did a port check, it returned that port 80 is open

    What did I miss or failed to do?





  • Try to clear states.



  • Already did a reset states, even reboot my pfsense


  • Rebel Alliance Global Moderator

    Well yeah port 80 would show open, its your pfsense web gui ;)  If your getting that from the outside.

    It should not be possible for you to hit your pfsense web gui from the public external side..  You don't show any rules on wan to allow such access - do you have rules in your floating tab that would allow that access?


  • Netgate

    In system advanced Admin check the Disable webConfigurator redirect rule.  I think that might take precedence over your port forward.

    The forward rule is allowing ingress on 80, I believe.

    You might also want to change the HTTPS configurator to a non-standard port.  I routinely use 8443.



  • @johnpoz

    I don't have any floating rules. In fact, I have reset to default my pfsense to make sure that I have to start from scratch configuring it.

    @Derelict

    i followed your instructions,  Disabled webConfigurator redirect rule, set protocol to https, on port 8443

    Still the same.  :(

    Tried to access my WAN IP from my phone, It displayed the page form my webserver BUT only if Chrome-Compression-Proxy is enabled. Also tried it from an external network, with  Chrome-Compression-Proxy plugin on Chrome, the intended page is displayed.

    Disabled the plugin, same result as above.. This is driving me crazy..



  • Netgate

    That's simply very unlikely.  Something is not how you think it is.  What's the WAN IP (pm if desired)?

    I have no idea what Chrome-Compression-Proxy is.  Are you sure you're not looking at a cached page in whatever you're doing on the browser side?



  • This is also my first time to come across with this Chrome-Compression-Proxy, https://developer.chrome.com/multidevice/data-compression. This is only available on mobile Chrome.

    Anyway, back to topic:

    The WAN IP on my pfsense is on 110.55.xxx.xx, port forwarded to 192.168.1.204 and i'm testing from 103.225.xxx.xxx.

    My purpose of this is to have vicidial accessible from our other office, starting from its web interface. I also didn't have much luck on port forwarding SIP and RTP (used by asterisk).

    If at least port forwarding work for http, I can also port forward other web application hosted in my other web server, which is also behind NAT. I'll find another way for vicidial.


  • Rebel Alliance Global Moderator

    are you using chrome mobile to check it - unless you turn if off it uses a proxy.  You would want to turn that off..

    As to pfsense listening on 80 and doing a port forward to something behind it listening on 80 - this is not an issue.  I just tested this and click click I was able to access server behind pfsense on 80 without issue.

    Was your phone on wifi or just cell access?  With wifi it most likely used that over cell data and now your doing a loopback because your coming from pfsense lan side.