APU1D4-Squid bug?



  • Hello,

    I installed a proxy (squid) for a hotel on a ALIX 2D13. It works perfectly.
    I wanted a newer hardware (APU1D4) and install pf and squid, but squid is a problem. It does not work when I reboot the system (or randomly after a reboot). Under Statut>services, it's green but it doesn't works (/var/squid/logs/access.log doesn't change when i use http websites and blacklist (in squid) is not active).

    I installed a clean version of pfsense 2.1.4 i386 (as alix2d13) and v2.7.9v4.3.4 squid (squid Version 3.1.20 pkg2.1.1 has the same symptoms).
    I have install and un-install pfsense several times(64 and 32bit). Only squid pkg without CP or other pkg.

    Thanks for your replys!

    Sorry for my English!
    ![Capture d’écran 2014-10-22 à 11.39.38.png](/public/imported_attachments/1/Capture d’écran 2014-10-22 à 11.39.38.png)
    ![Capture d’écran 2014-10-22 à 11.39.38.png_thumb](/public/imported_attachments/1/Capture d’écran 2014-10-22 à 11.39.38.png_thumb)



  • When I submit "save" (11:52:48 on my system.log) in Service> proxy server (without changing anything in the configuration), squid works.

    ![Capture d’écran 2014-10-22 à 11.57.46.png](/public/imported_attachments/1/Capture d’écran 2014-10-22 à 11.57.46.png)
    ![Capture d’écran 2014-10-22 à 11.57.46.png_thumb](/public/imported_attachments/1/Capture d’écran 2014-10-22 à 11.57.46.png_thumb)



  • This is almost certainly a configuration problem or just a squid or other package problem. 
    I doubt seriously its a  APU1D4 problem at all.



  • To me it just sounds like the service isn't starting at boot (or something like that).



  • I managed to find a PHP command (under Diagnostics> command prompt> php) which restarts SQUID:

    filter_configure ();

    But how to execute it until the startup of pfsense? How to run a PHP command with a shell script?( I'm an amateur-no professionnal)