Squid 3 package not installing on 2.2



  • Hello,

    I am attempting to install squid3 from the packages menu and getting the following error:
    pfsense version: 2.2-BETA (amd64) built on Tue Oct 21 13:21:00 CDT 2014 FreeBSD 10.1-RC2

    Installation of squid3 FAILED!

    Beginning package installation for squid3 .
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading squid3 and its dependencies...
    Checking for package installation...
    Downloading https://files.pfsense.org/packages/10/All/squid-3.1.22_1-amd64.pbi ...  could not download from there or https://files.pfsense.org/packages/10/All//squid-3.1.22_1-amd64.pbi.
    of squid-3.1.22_1-amd64 failed!

    Installation aborted.Removing package...
    Starting package deletion for squid-3.1.22_1-amd64...done.
    Removing squid3 components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file squid.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    done.
    Failed to install package.

    Installation halted.

    Is this not available on 2.2 as a pbi? Do I need to install manually via CLI?



  • this pbi isn't available, the freebsd port isn't available and I believe that is why it wasn't added. You can install squid3-dev. There is an issue getting it started but if you search the forum, there is a workaround.



  • Would you happen to have that link?
    I get: (squid), uid 0: exited on signal 11 (core dumped)
    And can't find a proper solution