Vyprvpn Port Forwarding



  • Hello everybody!

    I have been digging around on the forums trying to figure out a problem that I have come across with my pfsense box running my vyprvpn openVPN client.

    First off, I am not a network expert, and I apologize if my questions seem trivial to you experts out there  ;)

    I am at work now, so unable to send any config snapshots at the moment.

    So here is what Ive got…

    I managed to dig through about a half dozen forum threads and got my pfsense box set up running my openVPN client with vyprvpn. At the time of setting it up, I wanted to funnel all of my traffic through my VPN tunnel. I was secessful in funneling all of my network traffic through my VPN by doing the following things,

    1. Got the openvpn connection up and running.
    2. Created an interface for the openvpn connection to vyprvpn
    3. Put NAT configuration in manual, and duplicated each of the 3 rules with the interface being my openvpn interface.

    THAT secessfully put all of my traffic through my openvpn connection.

    Now I have a problem... I am wanting to open a port for a seed box that I have running. I dug and dug in the forums looking for people with similar problems, but was unable to get any of the suggestions to work.

    The first thing I did was went to my vyprvpn control panel on their website, and disabled the NAT/firewall on their end. That should have opened up the ports on their end.
    I tried several things... cant remember them all now, but...

    Created a rule for my vpn connection that was something like..

    Interface: VYPRVPN_INTERFACE
    Source:    ANY
    Destination: The ip address of my seed box.

    Ive tried multiple combinations of rules including changing the interface to WAN... ect..

    Whenever I go to canyouseeme.com to check the ports, it looks like every single port is blocked! Even port 80!  :o Now how can that be?

    Is it possible to do what I am trying to do? How would you go about opening the port up on the VPN conneciton?

    Responses are greatley appreciated! /cheers guys! Thanks for all the great posts!



  • I ended up getting this figured out over the weekend!  ::)

    Will post a follow up message when I get home on what settings I used to get it working… If anybody is interested that is..  ;)



  • I am interested.
    Which version of pfSense are you running?



  • Ummmmm…

    Sounds like something you were working on Mr. Wolf.



  • @kejianshi:

    Ummmmm…

    Sounds like something you were working on Mr. Wolf.

    Yup, still waiting for bugfix of reply-to in 2.2….. :)



  • Port forwarding finally works with the fix of https://redmine.pfsense.org/issues/3760.

    Great!



  • Good to know.