Squidguard, problem and error.



  • I have latest Squid(2.6.18), and SquidGuard(1.2.0_1) installed on my pFsense(1.2-RC5).
    I have two problems, first i cant choose what times the rules should apply, i could from the start but now i cant anymore, i dont know what setting i have set to make theese choices dissapear. Ive tried everything i can think of.
    Also at the top of the page on all tabs in the "Proxy Content filter" i have this error "Warning: Invalid argument supplied for foreach() in /usr/local/pkg/squidguard.inc on line 1306"
    In the screenshot both my problem and the error/bug should be visible.

    The thing i want to be able to configure is that i want to block certain sites special times during the day, or rather allow them certain times during the day.
    I.e, i want google.se to be blocked all day except 13:45-14:00.
    How should i configure the package to make it behave like this?

    Best Regards // Lars



  • Thanks for you post.
    I fixed error - pls reinstall SG and check for this error msg once more.

    About time
    You can use Time option in ACL's only (squidGuard future)
    For example

    • Select in Default page 'Default access - block all'
    • Add Time in 'Time' page
    • Add ACL with Source IP = you_subnet (for my example 10.0.0.0/24) or single ip's
    • Select Time in this ACL and define Destination rules

    You can use more ACL's, only remember about 'Order option'



  • Oh nice, thanks for the bugfix.

    Yes, ofcourse, stupid of me. Thanks:)

    However, now ive bumped in to a new bug, when i press "Apply" on the first page, i get this message:
    "Warning: Invalid argument supplied for foreach() in /usr/local/pkg/squidguard_configurator.inc on line 992 Warning: Cannot modify header information - headers already sent by (output started at /usr/local/pkg/squidguard_configurator.inc:992) in /usr/local/www/pkg_edit.php on line 35 "



  • Thanks!
    Fixed, pls testing new.



  • No more errors. Thank you very much.
    Will write again if i find anything else:)



  • Welcome¬† ;)


Locked