Pfsense HTTPS Portweiterleitung



  • Hallo Pfsense Team ich brauche Hilfe

    weil IPCOP nicht viel bittet haben wir uns Pfsense geholt. Habe pfsense installiert alles eingerichtet und funktioniert, internet, Email schicken und Empfangen.
    Aber Exchange OWA HTTPS 443 von aussen ist nicht erreichbar…habe alles probiert geht nicht. Aber wenn ich meine Alte IPCOP einchalte und LAN kabel anschliesse läuft OWA tadelos nur mir Pfsense halt nicht,
    WAS mache ich falsch...
    so sieht die Konfiguration auf Pfsense:
    Firewall NAT

    If                 Proto       Src. addr Src. ports Dest. addr Dest. ports NAT IP                 NAT Ports Description
    WANKABELBW TCP/UDP    *                     *         *     443 (HTTPS) 192.168.10.192 443 (HTTPS) HTTPS

    Firewall Rules
    ID Proto Source Port  Destination         Port   Gateway Queue Schedule   Description
          IPv4 TCP *           *       192.168.10.192 443 (HTTPS) *       none             HTTPS

    Auf Ipcop ist nur portweiterleitung HTTPS sonst nicht, und lauft allles. Was muss man noch auf Pfsense machen damit OWA geht

    Ich brauche ihre Hilfe
    Danke!





  • Guten Morgen sondavid,

    soweit sieht das ja richtig aus. Das einzige was ich mir nun vorstellen kann ist das die sense selbst auf 443 lauscht und dort ein wenig durcheinander kommt.

    Schau mal im System -> Advanced nach ob die sense auf HTTP oder HTTPS steht.

    Und stimmen die Interface wirklich? Ist nicht ganz zu erkennen aus deinem Post.

    LG



  • Warum graust du bestimmte Bereiche in den Screenshots aus und postest die Daten dann in den Text ? :D

    Anyway, versuch mal bei der Firewall Regel das Logging an zu schalten und schau mal ob du erstmal überhaupt traffic auf der Regel bekommst.
    Dann versuch mal ohne Destination IP zu arbeiten um zu sehen ob das klappt.



  • Hallo Team
    Danke für die Antworte.
    @Wexxler
    Pfsense ist auf HTTPS, habe ich auch HTTP gestellt bringt auch nicht, muss vielleicht neustarten  :'(

    @Satras
    habe alle möglichkeiten versucht, muss ich immer danach neustarten ?

    Hier nochmal die Bilder

    Danke






  • Entferne doch mal zum Testen das UDP aus der NAT und der Rule.



  • @Wexxler:

    Entferne doch mal zum Testen das UDP aus der NAT und der Rule.

    Habe geade gemacht, pfsense neugestartet, hat leider auch nicht gebracht.  :'(



  • weil ich da kabel lese.
    Macht die PfSense auch die Interneteinwahl oder hängt nochmal ein Router davor?



  • @flix87:

    weil ich da kabel lese.
    Macht die PfSense auch die Interneteinwahl oder hängt nochmal ein Router davor?

    Pfsense macht die Interneteinwahl und hängt an Kabelbw Modem.

    Danke!



  • Hast du mal in der NAT Regel das Destination auf any gesetzt statt WANKABELBW address?



  • wenn du diese NAT Regel testest sitzt du dann selbst hinter der PfSense oder komplett von Extern?

    Wenn du selbst auch hinter der PfSense sitzt bei der NAT Regel mal NAT reflection auf enable (Pure NAT) stellen.



  • @flix87:

    wenn du diese NAT Regel testest sitzt du dann selbst hinter der PfSense oder komplett von Extern?

    Ich teste alles von extern, habe ein Pc der an andere WAN Leitung hängt

    Wenn du selbst auch hinter der PfSense sitzt bei der NAT Regel mal NAT reflection auf enable (Pure NAT) stellen.

    habe auch gemacht, soll ich lieber pfsense neu aufsetzen, vielleicht ist irgendwo was falsch..

    Frage wie soll eingentlich so was aussehen:

    NAT und Firewall Regel?
    Ich will nur Zugriff auf HTTPS OWA von externe aus.

    Danke



  • Die Regeln sollten so passen.
    Wenn du nur OWA willst brauchst du auch eim SMTP auf machen da reicht HTTPS



  • Hi,

    wie die Vorredner schon gesagt haben, sollte man den Admin-Port von pfSense auf was anderes als 443 legen, z.B. 444 und dann die Postweiterleitung. Teste bitte unbedingt von extern (z.B. Handy per UMTS) und dann aktiviere NAT Reflection. Dann sollte es auch aus dem internen Netz geben.

    Ich nehme an, der OWA Server befindet sich hinter pfSense. Ich glaube OWA ist nicht wirklich NAT-freundlich. Ich selbst betreibe übrigens diverse Server hinter einer öffentlichen IP, dazu verwende ich Squid3-dev als Reverse Proxy. Ich habe dort nämlich gesehen, dass es spezielle Einstellungen extra für OWA gibt.

    Eventuell geht es nur über diesen Weg.

    ![Screen Shot 2014-10-31 at 10.39.13.png](/public/imported_attachments/1/Screen Shot 2014-10-31 at 10.39.13.png)
    ![Screen Shot 2014-10-31 at 10.39.13.png_thumb](/public/imported_attachments/1/Screen Shot 2014-10-31 at 10.39.13.png_thumb)



  • @dkrizic:

    Hi,

    wie die Vorredner schon gesagt haben, sollte man den Admin-Port von pfSense auf was anderes als 443 legen, z.B. 444 und dann die Postweiterleitung. Teste bitte unbedingt von extern (z.B. Handy per UMTS) und dann aktiviere NAT Reflection. Dann sollte es auch aus dem internen Netz geben.

    Ich nehme an, der OWA Server befindet sich hinter pfSense. Ich glaube OWA ist nicht wirklich NAT-freundlich. Ich selbst betreibe übrigens diverse Server hinter einer öffentlichen IP, dazu verwende ich Squid3-dev als Reverse Proxy. Ich habe dort nämlich gesehen, dass es spezielle Einstellungen extra für OWA gibt.

    Eventuell geht es nur über diesen Weg.

    Hallo Danke sehr

    hast du eine Einleitung wie das mit "Squid3-dev als Reverse Proxy" geht?
    kannst du mir bitte vielleicht mailen, bin seit einer Woche schon an dran.

    Owa bzw Exchange Server befindet sich hinter pfsense.

    was auch bischen komisch ist, bei IPCOP haben wir nur portweiterleitung 443 auf Exchange server eingerichet und funkt alles tadelos. nicht viel nicht weniger.
    Wieso bei pfsense ist alles so kompliziert?

    Danke!



  • Guten Morgen,

    @dkrizic:

    Hi,

    wie die Vorredner schon gesagt haben, sollte man den Admin-Port von pfSense auf was anderes als 443 legen, z.B. 444 und dann die Postweiterleitung. Teste bitte unbedingt von extern (z.B. Handy per UMTS) und dann aktiviere NAT Reflection. Dann sollte es auch aus dem internen Netz geben.

    Ich nehme an, der OWA Server befindet sich hinter pfSense. Ich glaube OWA ist nicht wirklich NAT-freundlich. Ich selbst betreibe übrigens diverse Server hinter einer öffentlichen IP, dazu verwende ich Squid3-dev als Reverse Proxy. Ich habe dort nämlich gesehen, dass es spezielle Einstellungen extra für OWA gibt.

    Eventuell geht es nur über diesen Weg.

    So ganz kann ich das nicht bestätigen. Selbst betreibe ich auch eine OWA hinter einer sense (2.1.4) über den Default Port 443 und es kommt zu absolut gar keinen Verbindungsproblemen.

    LG



  • Hallo
    habe hingekriegt, das lag an Firewall regel, Pfsense HTTPS.
    Habe pfsense auf andern port laufen lassen, und die Ferewall regeln  bei WAN  Dest. addr auf WAN adresse geändernt und tatatat  alles gut. Übrigens habe pfsense auch neuinstalliert.

    Danke!


Log in to reply