Getting UGAs via Router in front of pfsense / IPv6 network delegation



  • Hi everybody,

    I'm not getting it. It's usually quite simple but pfsense doesn't make sense to me. :D

    I have a proper router cascade with 2 Fritz.boxes. the second box is getting an prefix from the first one and spread the UGAs as supposed to be.
    But I have no idea whats going on with pfsense.

    heres an overview:

    working:

    Fritz.Box 01 prefix ::/56 -> Fritz.Box 02 prefix ::/62 -> UGAs on Clients at the LAN side

    not working:

    Fritz.Box 01 prefix ::/56 -> PFSense -> no UGAs on Clients at the LAN side

    I put an IPv6 static adress on the LAN side Network but still no prefix available.
    There are some Options but I ticked them and nothing happens. I'm not really sure.They shouldn't useful anyway because it's looking like Delegation.

    Can anyone Help me with that?
    It should be simple but I can't find a way to get it running. :(


  • Rebel Alliance Developer Netgate

    If you want pfSense to pick up and use a delegated prefix then:

    • WAN must be set to DHCPv6
    • You must have the proper delegation size filled in on the WAN settings.
    • LAN must be set to track6 with the WAN chosen
    • LAN must have a delegation prefix set (typically 0)


  • And in addition to jimp; in FB you specify the prefix-size which you then use with pfSense.

    For FB config "Require certain length for the LAN prefix": let's set : 64
    Then pfSense WAN: "DHCPv6 Prefix Delegation size" : 64; "Send IPv6 prefix hint" : true

    And reboot the pfSense, FB, or both in logical sequence.



  • Hey guys,

    Thanks for your help.
    I did exactly what you described but hdas Addition was the missing Piece and got me on track.

    It is now working as I thought it has to be and similiar to my second Fritz.box.
    I'm playing around a bit and will come back if I have more questions.

    Thanks again.  :D