HE.net tunnelbroker DynDNS issue

  • Hello,

    I configured my IPv6 tunnel using HE.net tunnelbroker successfully, connectivity is up and running :)

    However, I chose to setup DynDNS to allow my IP to update in case it changes but it doesnt work; the "cached IP" is always "N/A" and system logs are showing this:

    php: /services_dyndns_edit.php: phpDynDNS: (Error) Invalid username or password.

    I'm a bit confused as I configured it according to this tutorial:


    Hostname: he.net tunnel ID
    Username: same as I use to log into my account's web page
    Password: same as I use to log into my account's web page

    Any idea what Im doing wrong? (yes I quadruple checked I entered password correctly!)


    Found the issue:

    password is actually the "UpdateKey" located under the advanced tab of he.net tunnel advanced settings!

    Maybe update the pfsense doc accordingly?

    Sorry for the trouble :)

  • Rebel Alliance Developer Netgate

    They must have changed that and grandfathered us old folks in. Mine is set to my account password right now and works. :-)

    I'll add a note to the doc that it may need to be the update key.


  • Here's the post that was published on the account's main news feed:

    Authentication updates
    [January 31, 2014]
    In order to improve account security, some changes have been made to how tunnel endpoint updates are authenticated.

    Tunnels made after this post now are configured with an "Update Key" (under the "Advanced" tab on the tunnel information page), which is used instead of the general account password when performing automated updates via either the https://ipv4.tunnelbroker.net/ipv4_end.php or the /nic/update (Dyn-alike) mechanisms.  Do not MD5() this value before use.

    When an "Update Key" exists, the account password will not work for updates on that tunnel.  Existing tunnels can set an "Update Key" to take advantage of this new mechanism.

    Thank you for updating the docs! :)