3D Modem ZTE MF190



  • hi, i've tried to get a ZTE MF190 working with pfsense.
    I almost got i working, but encountered a probably small problem: i've been getting this error:

    
    CHAT: Invalid dial init string.
    
    

    it does say this, after trying to dial ATDT*99#
    now i'd like to change ATDT to ATD, but there isn't any option, neither can i change the config /var/etc/mpd_opt1 something where it does say something like dial string ATDT

    has anyone an idea how i can change this dial-string prefix?
    or can someone add a option field for the dial string? :D


  • Netgate Administrator

    If you click the 'show advanced options' button on the PPP edit screen you can enter the modem init string.

    Steve



  • To manually set the string go to /ect/PPP/ppp.conf



  • I just learned how to do this and can offer these tips
    Note:/ect/PPP/ppp.conf must be edited as it seems that PPP device settings under Interfaces do not stick. It seems the sample ppp.conf file never gets touched after picking an interface. Mine has cuaU1 as default in ppp.conf even if I change PPP settings in the web gui. So start there. Find your correct usb device address for AT commands and use that. Finding this port is the hardest. I have found this website really helped

    http://technotation.com/

    One really basic way to see system modem messages is goto pfsense shell from the console and type PPP and then set device and start sending AT commands with TERM. If you have the right usb interface/device the modem talks back. ATZ,ATI OKOKOKOKOK

    Actually i cheated and used Windows. Mine was cuaU0.4. Found device ID from device manager then worked backwards.
    Good luck
    OK



  • And i really hope you mean 3G Modem and not 3D modem as those may not be supported yet !!!



  • And to muck things up even more for you there are usually 6 interfaces assigned to the Sierra devices that i experimented with. There are two devices that will take AT commands. A managment port and the real modem port you need to use . And the GPS gives off COMM data filling TERM jamming everything up if you end up there…
    That is pretty much my experience in a nutshell. The PPP/system logs really help but not until you get the correct usb interface set. There are also settings in RC.conf


  • Netgate Administrator

    I prefer my modems 3D certainly.  ;)

    I'm not sure you're going about that the right way. What file were you looking at that didn't change when you edited using the webgui?
    If you edit the files directly then any changes you make will not be in the config.xml file and hence won't survive a firmware update or a restore.

    Steve



  • I just did a stock 2.1.5 install and tested. I had to edit ppp.conf -just "set device"and "set speed" and I am unsure the latter is needed. The ppp.conf never changes for me. This is my fourth separate device installation(stable and beta). I am not complaining, simply want to make sure this little thing doesn't stop someone from enjoying pfsense. Easy edit now that i know. Here are my steps:(straight from the 3G/4G modem setup page)
    Create WAN from console.
    Fire up GUI
    Create PPP from Interfaces tab>Picked device cuaU0.2(sierra AC881)Saved: link type PPP
    Assigned to WAN Interface>Enabled>
    Reboot
    At this point it don't work. Fire up console Go to PPP>TERM wrong device –shows ppp.conf setting of cuau1. Nothing changes in the ppp.conf file from gui configurations.

    Manually edit ppp.conf with proper device, reboot, instant WAN IP on console(from aircard), I know its working from there.

    I am either thick or it ain't changing. 4 plus machines tested all different sierra devices.

    Just wanted to check to see if I am the only one. Thanks Frank


  • Netgate Administrator

    Hmm. I don't have much experience using 3g modems but when I have it just worked.
    When you create the ppp interface I expect a file to be created in /var/etc (/ppp?) named soemthing like ppp0.conf. That file is created at boot (or when you create the interface) from the default ppp.conf file and the customs values held in the config.xml file.
    I'm not entirely sure what you mean by 'Go to PPP>TERM' but is that perhaps using the default conf file /etc/ppp instead of the custom one in /var/etc?

    Steve


  • Netgate Administrator

    Ok, so a quick test shows it's almost as I expected. The config file appears in /var/etc as mpd_opt7.conf. OPT7 happens to be the interface I assigned it to. It must be assigned and enabled before the file is generated. Inside the file are any changes to the defaults defined in the ppp config including the dialing prefix, which is set by default as 'DT'. However I'm not sure that's possible to alter via the webgui, the modem init string is a different variable.

    Steve


Log in to reply