PFSense Crashes



  • Hi,

    Can someone point to me where should i check, my box keeps on crashing randomly:

    Fatal trap 12: page fault while in kernel mode
    cpuid = 3; apic id = 03
    fault virtual address	= 0x420
    fault code		= supervisor read data, page not present
    instruction pointer	= 0x20:0xffffffff8023be83
    stack pointer	        = 0x28:0xffffff804884a5a0
    frame pointer	        = 0x28:0xffffff804884a5d0
    code segment		= base 0x0, limit 0xfffff, type 0x1b
    			= DPL 0, pres 1, long 1, def32 0, gran 1
    processor eflags	= interrupt enabled, resume, IOPL = 0
    current process		= 0 (em0 taskq)
    version.txt06000022012425602270  7605 ustarrootwheelFreeBSD 8.3-RELEASE-p16 #0: Fri Jun 20 13:19:29 EDT 2014
        root@pf2_1_1_amd64.pfsense.org:/usr/obj.amd64/usr/pfSensesrc/src/sys/pfSense_SMP.8
    


  • This is a tricky one! It's freebsd related.
    Most likely hardware issue. Memory modules could be the cause but not necessarily.

    Check out this thread:
    https://forum.pfsense.org/index.php?topic=68590.0

    I experienced something like this and in my case it was indeed a memory problem. I changed the timing of the DRAM (slowed down memory access) and got an additional 6 months before failure.

    BTW, how much memory do you have in your system?

    Halea



  • thanks for the reply, I got 6gb memory inside the box. I hope its memory.



  • 6GB of RAM is plenty of memory, so it's definitely not a question of memory shortage.
    I'm guessing that your 6GB is configured as 2x2GB+2x1GB (therefore you have 4 modules, 2 of 2GB and 2 of 1GB). If that's the case please make sure that the memory modules of the same capacity are exactly identical (make, model timing, etc) and the 2GB and 1GB modules have the exact same timing.
    In doubt, drop the 1GB modules and reduce the memory to 4GB (2x2GB) and see what happens. (you need to run it for a while to see if the failure still happens)
    Now, you said very little about your machine, how old the hardware is, is this a new install, has it worked better before and this started to happen suddenly without you changing anything, etc.
    I'm focusing on the RAM but it could actually be a number of other hardware things.
    Halea


Log in to reply