No serial console after installing 2.1.5 from USB



  • Hi everyone!

    I have a running pfSense installation on my Jetway Barebone[1]. It is running fine from the CF card, also the serial console is working as expected. The installation method I used back then was using an image that I have dd'ed to the CF.

    Yesterday, I've put in a Mini-PCIe-SSD and wanted to re-install pfSense. Therefore I've downloaded the Live-CD-USB-Serial-AMD64-Image[2] and prepared an USB key for booting.

    On boot I chose "3. Boot pfSense using USB device", then in the selection after that I chose (I) for "Install". I selected the "< Custom Install >" method for installing. At the end, because I have a Dual-Core-CPU, I chose "Symmetric multiprocessing kernel". Then I chose "Reboot".

    The installation itself worked without any problems so far.

    After reboot, however, I lose the serial console so I can't continue setup. As the box asks for a setup of the interfaces it won't boot to a point where I could access it via the web interface.

    I do have two serial (com) connectors on the box, however, neither of them works.

    How can I get the serial console to work?

    Regards
      Steffen

    [1]http://www.jetway.com.tw/jw/Barebone_view.asp?productid=1012&proname=JBC373F38-525-B%20/%20JBC373F38W-525-B
    [2]http://pfsense.mirrors.ovh.net/pfsense.org/downloads/pfSense-memstick-serial-2.1.5-RELEASE-amd64.img.gz



  • I experienced the same thing.  I basically had to put the usb back on for the boot process to continue.



  • I managed to fix it. Here is what I did:

    • Boot from USB

    • In the dialog, select "Live CD", not "Install"!

    • Boot pfSense live system

    • Configure interfaces properly

    • Install pfSense trough (serial) console (menu choice "99")

    • At the end of the install DO NOT REBOOT YET

    • Enable sshd trough the web interface

    • Connect to the box via SSH

    • Go to the boot folder of the newly installed system (should be /mnt/boot)

    • Edit the loader.conf (e.g. vi loader.conf)

    • Add the following two lines, save and close
      console="comconsole"
      comconsole_speed="9600"

    • Let the box reboot via the installer in your (serial) console

    This way I managed to fix it.

    Regards
      Steffen



  • No need to manually edit anything, just choose the "embedded" kernel option when doing the install. If you need a serial console post-install, that's the way to do it. The kernel doesn't have VGA but is otherwise the same.



  • Well, as the "other" kernel explicitly stated "Symmetric multi processing" I thought I would lose that ability when choosing the "embedded" kernel. Maybe the selection should be clearer…



  • The options in 2.1.5 are labeled "Standard Kernel" and "Embedded kernel (no VGA console, keyboard)". That's about as clear as it can be I'd say. There hasn't been any explicit mention of SMP in a while, as all kernels have had SMP the last few releases.



  • @cmb:

    The options in 2.1.5 are labeled "Standard Kernel" and "Embedded kernel (no VGA console, keyboard)".

    In fact they are not labeled in that way. I didn't make that up.

    I just fired up a virtual machine and started the installation to make a screenshot. What you can see in the screenshot is the very same thing you will see in the installation via a serial console.




  • Ah, thanks, the serial console one pulls from a different file. The memstick/ISO one is labeled as I described. I just updated the serial one to match.


Log in to reply