Connection to specific website slow with intervals

  • I'm having a strange issue I cannot seem to resolve.

    Site has a 2.1.5 x64 setup running with no specific packages, VPN's or anything special except 1 additional VLAN not even in use (yet)
    On location they use 1 specific external website to basically do 99% of their daily activities.

    But, the website has moments where its almost unreachable, it goes very slow and very rarely times out.
    I tested the website on different locations without major issues - off course, I don't test this 4 hours straight like they do. Which doesn't help trouble shooting really..
    All systems internally are Apple's, the 3 Windows systems do not seem to have this issue. Trouble is is that the Windows users don't use the website as frequently.. which again doesn't really help.
    I tested on site with an W8 notebook for 1.5h without issue while the Apple Pro book I was using at the same time had trouble. All connected by cable, or wifi. (tested both).

    I tried adjusting the following

    • playing with hardware offload settings
    • adjusting firewall to conservative
    • enabling IP Do-Not-Fragment compatibility and IP Random id generation
    • QOS'ing the specific website's IP in question
    • Throttling/limiting down the connection to 30/5 for everyone, to see if the it maybe was a speed issue.

    To no major resolve. Often they claim it goes better for an hour or 2, then its back to normal.
    Other websites do not have this issue. But off course are not used by 25 people at the same time neither.

    Any idea what I may be missing or something I can try except for swapping it out?
    pinging for hours straight does not give a noticeable result regarding latency. Packet capturing didn't know anything special.

    Setup is an G2130 with 4GB memory. Connection is a Cable 200/10 MB. Switch is an HP 1910 connected by trunk port to pfsense.
    Motherboard is a Jetway (Intel I211AT & I217LM) with an additional add-on Intel CT card.

    Location has a second VDSL line as backup. Moving certain people to that connection did not seem to resolve the issue.
    So either its the way pfsense communicates with the providers devices & network, or its the way it handles connection from OSX.

    If any one has an idea, do throw it out. Swapping hardware out is the last resolve i'm not really looking forward too. (majorly since i'm pushing for pfsense to replace most sites current setup).

  • Never know this can help anyone else but..

    Swapped out 2 completely different hardware boxes, and even other commercial firewalls and SOHO routers. Even switches were replaced.
    In the end the problem were the clients as was my original guess..

    Apple systems were updated to Yosemite, all problems solved.

Log in to reply