Http 1.0 protocol is not supported



  • Hello.

    I have a problem with accessing to one of a internet-banking sites. When i try to open site in IE (i tried many versions) i get error "http 1.0 protocol is not supported". Other browsers shows "…use only IE...." becouse they are not supperted, only IE. This is usual site, without any encription, nedds only 80 port. Of course in IE advanced options "use http 1.1" and "use http 1.1. proxy" enabled. This problem only in corporate LAN.

    What i should to do to slove this problem? I use pfsense hardware C2758I

    P.S. This site works fine from my home desktop and form other internet cafes


  • Netgate Administrator

    What internet banking site doesn't use encryption?  :-\

    Are you running Squid? Which version?

    Steve



  • Why are you trying to connect to an HTTP1.0 non-encrypted banking website? In most countries, it would be illegal to have such a site.



  • Really it's not so easy. When i open the website from my home PC, it opens well (loads http, not https), then after entering login/password i must install ActiveX componet (for the first time) (it is not a capicom), and only after this manipulation loads "applicaton" in wich i can work, and traffic from this application to Bank's servers encrypted. All communications are using 80 port. I said "internet-banking without encription" becouse encryption starts only when I logon the application, before it i see typical web site. So, when i try to access to internet-banking site from corporate network (behind PFsense) i get error "http 1.0 protocol is not supported" i don't see any login/password fields only error on white backgroud.

    My PFSense version 2.1.4-RELEASE (amd64) built on Fri Jun 20 12:59:50 EDT 2014  AND Squid version 2.7.9 pkg v.4.3.4


  • Netgate Administrator

    Have you tried disabling Squid as a test?
    If that works you could exclude the bank site from the proxy.

    Steve



  • @stephenw10:

    Have you tried disabling Squid as a test?
    If that works you could exclude the bank site from the proxy.

    Steve

    YES!!!! This problem was in Squid, when i entered my IP in "Bypass proxy for these source IPs" site wil work fine! Thanks a lot.

    P.S. I'm trying to stop squidguard but it is not take effect. Why squid blocking? My rules are allow all traffic.


Log in to reply