Squid does ignore firewall (routing)rules



  • Hi,

    I've got two outgoing interfaces on pfSense. The usual WAN and a OpenVPN connection.
    I use squid mostly to block ads and use the VPN to bypass restricted YouTube videos (I'm from Germany and there is a thing called GEMA that no one likes).

    There is a firewall rule on the LAN interface, which takes everything and routes it through the VPN interface.

    Sometimes, the VPN get's a RTT of 300ms and more, which makes me change this rule to route traffic through the normal LAN interface, because everything is awefully slow.

    If I do a tracert, the VPN isn't used anymore and everything is great.
    The browser however still connects through the VPN and whoer.net tells me, I'm still located in Switzerland.
    If I turn off the proxy in Firefox, everything is back to normal. If I turn it back on, I'm in Switzerland again.

    How do I tell squid to recheck, where traffic should go?

    Reseting the state table and restarting squid/pfSense doesn't do the trick.

    Edit: I'm using squid 3.1.20 pkg 2.1.1


Log in to reply